Flipper stuck in DFU

Hello everyone,

My Flipper Zero is stuck in DFU, this is how it happened :

A morning while taking my Flipper it was locked, i never lock my Flipper so it was a bit unusual, i pressed the Back button three times but nothing happened, the time was correct so i didn’t think the Flipper was frozen but i solve a lot of problem by hard rebooting it so i pressed the Left and Back button together, then releasing them as soon as the screen turn off, I have done this a lot of times and i know how to reboot the Flipper, but it restarted in the DFU mode so i restarted again using the same technique as before and DFU again, after a bit of googling i have found the method to boot in DFU was different so i was right in my way of rebooting the Flipper and i should have been taken to the Flipper Desktop

I did not take a video of my Flipper locked because i don’t think it was such a big deal, but this guy did and the same thing happen to me : https://www.youtube.com/watch?v=bW5YjUO91sY

Now in DFU mode i can restart my flipper almost instantly by pressing the Back button and here is my video showing the issue and attempting a firmware flash using qFlipper : https://youtu.be/ZYkgR7WkK8E

The qFlipper app crash at the end, tried on Linux and it crashed too, tried with the “Install from file” and it’s exactly the same thing (Tried on 4 PC 2 Windows 1 Linux 1 Mac with different cables)

qFlipper logs : qFlipper logs - Pastebin.com (the logs from the others PCs look the same but i can provide them if needed) i think after the flash the flipper is supposed to boot to Desktop but instead boot to DFU and the qFlipper app does not expect that

The flipper was not dropped and always protected with the official case and screen protector, the battery was almost full when this issue begin and the Flipper is about 8 months old

Tell me if you need me to try something on my Flipper, I’m really sad that it’s broken :frowning:

Thanks and have a great day :slight_smile:

1 Like

See what happens if you try to reboot the Flipper without the SD card. If the Flipper seems to work try to put the SD card back in. That should verify the SD card didn’t somehow go bad.

You could try installing an older version of the firmware.

You could also try to using https://lab.flipper.net/ in Chrome although I think the chance of that working is low.

Trying to reboot without an SD Card does the exact same thing (Flashing without SD Card does the exact same thing too)

I did tried to install version 0.53 that i found here : Flipper Zero Firmware Update
File : “flipper-z-f7-full-0.53.0.dfu”
but it didn’t work aswell (With and Without SD Card)

I don’t have Chrome so i used Edge Chromium but it didn’t find anything to connect to

Thanks have a nice day

1 Like

The Flipper can’t be flashed without an SD card inserted. If you have another SD card you could try replacing the SD card. I don’t think that’s your problem though.

Since the process is starting properly I don’t think this is a driver issue but it’s worth going over the troubleshooting. In particular you should expect to see the DFU driver.

With a different SD Card it does the same thing

My driver on my first and second Windows PC have
Name of device is : DFU in FS Mode
Driver provider : STMicroelectronics
Driver date : 07/05/2018
Driver version :
Digital Signer : Microsoft Windows Hardware Compatibility Publisher
Tried reinstalling qFlipper multiple times and always got this driver
I also unistalled it with the “Delete drivers” checkmark on

And on my Linux machine, lsusb list it as “STMicroelectronics STM Devices in DFU Mode”

It really look like the Left Arrow is stuck on

Have a nice day :slight_smile:

We can verify your theory fairly easy. I held the left key down manually to simulate a stuck button. Whenever I hold the back key down for 3 seconds the Flipper restarts. Then I stopped holding down the left key to simulate an unstuck key. Now if I hold down the back key the Flipper will not restart but instead it will ask if I want to “turn off the device”.

It will be interesting to know if holding the left key while flashing make qFlipper crash but it can be dangerous so you shouldn’t try it ^^

As you can see in my video, my flipper hard reboot simply by pressing back button for 1-3 seconds.

My key is clearly not physically stuck, i can feel it clicking just aswell as the others keys

I missed that when I watched the video. If you are comfortable doing it the Ifixit tutorial explains taking Flipper apart and reassembling. It makes sense the Flipper would fail to update with the left button stuck. The Flipper must reboot during the process and with the left button down it always thinks it must reboot in DFU. Canned air might be a way to get the button unstuck though.

I already did, but it didn’t make any difference :confused:
There is a thread were a guy as the exact problem as me : Flipper stuck in DFU mode - #9 by vhoofj

And in this thread Astra said :
That looks like a faulty component in the button assembly. Please contact [email protected] and send them a link to this thread.

I have contacted them via e-mail, but they no longer answer my mail; it’s been almost a month now and i miss my flipper, i have a lot of projects that i want to work on involving my Flipper :confused:

Sorry to hear that.