NFC emulator not working

I just received the flipper and everything seems to be working. Scanning and emulating of RFID tags, sending IR signals and reading NFC cards. But when I try to emulate a NFC card Flipper is showing the icon that it is emulating, but when I scan it with my phone or another NFC reader, nothing is received. I tried all sides of the flipper, and with multiple different cards.

Is this a hardware issue, or am I missing out on something?

What type of card are you trying to emulate?

Thanks for the (really) quick reply!

I tried with a student ID card, but I also downloaded some MF Ultralight files (Flipper/NFC/Fun_Files at main · UberGuidoZ/Flipper · GitHub). Nothing is recognized on the readers.

My ID card emulates well on desk readers and copy machine but not on doorlocks with the same NFC? Maybe try a couple of different readers?

What kind of card is your student ID card? Also, on what readers are you testing the emulation?

@Astra What type is it that you want exactly? The scanner reports a Mifare DESFire ATQA: 4403 and SAK: 20
I also have another Mifare Ultralight/NTAG card from an arcade.

Both can be read from my mobile phone NFC reader, but nothing is received when I try to emulate with the flipper and read from my phone (tried a oneplus and a samsung).
I also just tried the amiibu files on my nintendo switch, and it did work there.

So is it correct that most cards cant be emulated (or at least not to a android NFC reader)?

DESfire cards can’t be emulated. NTAG/Ultralight cards have to be read completely (via “Run Special Action”) to be amulated properly

Can DESfire cards not be emulated in general? Or only atm?

Wouldn’t wait for it

1 Like

I have problem with emulate Mifare Classic 1K. Flipper read memory, but cannot emulate keys from this card.

1 Like

The emulation isn’t perfect yet, please wait for future updates

Someone has already reported this problem to you?

Yes, this is a known issue


I am seeing the same issue.
I can copy and use the emulation to open doors (mifare classic 1k card) but it is not recognized by the readers of the attendance registration of the building. My phone (Huawei Mate 20 pro) doesn’t see emulated cards either.
So it depends on what technology the reader uses?
I also have a cheap AliExpress NFC reader/writer which does seem to recognize the Flipper emulation.

Still not working with my flipper


Change in File xxx.nfc

Setting 1:

ATQA 00 04
SEK 08

Setting 2:
ATQA 00 00
SEK 00

Both works for me and my Homekey. :slight_smile:
Not for my Office. :frowning: