Won’t detect garage opener

This is probably such a noob question but I’m having trouble getting my Flipper to detect my garage opener. I open the Sub-GHz app and turned on the frequency analyzer. When I press the button on my garage opener it shows between 314-315MHz on the screen. So then I go to Read and choose 315MHz and scan while pressing the garage opener but nothing happens. I tried every optIon for Modulation too.

Am I missing something? It’s a Liftmaster garage opener in case you’re wondering.


Same issue here.

Same; my opener says 318mhz though. Not seeing anything even with the analyzer.

first, it uses rolling codes so you cannot capture and keep
second, there are a few users who are having issues with 125KHz and rolling back to .50 will fix that

Ok, even with rolling codes, strange that the flipper won’t even see it on the analyzer (for me at least). I guess it just can’t hit 318mhz?

1 Like

they work exactly at 318.000? Can you take a photo of the nameplate on the keychain?

The brand is ‘Linear’, when I do a quick Google search for ‘linear garage door opener frequency’ 318mhz immediately pops up. It’s also stated on the opener itself.

I can confirm also I have a Linear model MT-1B with frequency 318 MHz listed on the back. My Flipper also does not pick up any signal on the analyzer. In the ‘Read’ section, what Modulation should I be set to?

Tomorrow you have to add this PR to the dev, you can update it, and then the analyzer will see 318 and will be able to record the RAW signal. also try to recognize the signal through Read, and if it doesn’t recognize it, please send me a RAW (AM) recording of 10+ clicks of each of the buttons, I will look at it and maybe add it to Read

1 Like

try https://github.com/flipperdevices/flipperzero-firmware or dev


After updating to newest dev firmware the analyzer now sees 318 coming in! Read still does not pick it up no matter the modulation I choose but it does sit at 318 when ‘hopping’ is turned on and I press the openers’ button. Recording the signal raw set to 318 comes in strong and exactly as expected, I am not near the gate this clicker works with to test it unfortunately… If you’re ok with a little hand holding I can try to get you the recording… I have it saved to my Flipper, now, how do I go about getting it to you? I’ve figured out how to save backups but haven’t gotten as far as pulling specific files for export yet…

if read does not see it, then the flipper simply does not know this protocol. send a photo of the remote control 2 sides FCC-id , and record raw 10+ clicks of each of the buttons. You can download it by simply inserting the SD into the card reader

1 Like


@SkorP - Just following up on this thread. I have the same issue with a MyQ / Chamberlain garage door opener. I’m on the latest firmware (0.50.0). It shows 314/315 in the analyzer but I’m not able to add it using ‘read’. Is this a known issue with LiftMaster products (LiftMaster owns Chamberlain - same/similar products).

1 Like

this is NOT a problem, the flipper simply does not know this encoding, I do not have such a system in my hands, if you want flipper to support your systems, you first need to! ⚠️ My remote isn't supported | How to add new Sub-GHz protocol in Flipper Zero


@SkorP - Ah, good to know, thank you! I’ll follow the directions and request for it to be added.

linear’s mtr3 remote does work with the f0 in raw mode, including replay. 318.00 / AM270

and I think it’s the same for the mt-1b

My remote was liftmaster(long button, forgot model#, see attached image) FCC ID: HBW1573

I didn’t look at the forums completely because I just scanned the first few replies and saw that people couldn’t get it working. It wasn’t until I looked at the FCC ID that I realized how it works.

Initially, I tried to read(raw) 315MHz, 650FM my already programmed garage remote and emulate it onto the garage controller which didn’t work.

I then looked at the FCC ID and it’s relevant documents. Found out they have a schematic posted and BOM(attached) as well as their theory of operation which was great info!

So after looking at the circuit, I saw that I can hook up two more pushbuttons if I wanted to. It uses an atmel encoder(125C0130)to spit out a code depending on which input it gets. My remote had a different encoder but it started with the same number 125C0xxx and I’m pretty sure same pins.
I looked at other HBWxxxx FCC ID and from looking at the schematics, they basically use the same chip with slightly different variation thereby being the same circuit.

So since mine only had one long button on it, meaning it had one push button. If I really wanted to, I could short out one of the non-populated pushbuttons and read the code out of that chip and have the flipper read it (since it will be a new unlearned code), then program the flipper from the garage controller. This is equivalent to buying a new garage remote, flipper reads it, then have the garage controller learn the flipper. So FYI, if anyone has those one or two button lift master remote, know that you can hook up to three buttons if you wanted to, you just have to modify it a little bit by soldering on another pushbutton and removing the jumper on the remote pcb. The schematic shows 4 buttons, but two of them are going to the same input.

So it wasn’t until I came to the forums that I realized that there was already some work done on this and I just had to go “add manually” on the flipper and use the liftmaster 315 to essentialy emulate a new remote. Shout out to the developers: Thanks for the add! Great work!

What bugs me is the fact that I can’t emulate a learned remote. After looking at the garage remote, it was developed in the early 2000s, so I’m pretty sure they didn’t use Security +2 which uses rolling code and highly confident that the current remote that I have uses a Security +1 protocol. So, if it’s not using a rolling code, why is the garage remote not recognizing a learned remote’s signal/word?

Also if anyone could point me towards documentation of how Security +1/+2 works, please do. I did a basic google search with the words security +1/+2 protocol and I couldn’t find anything. Then I saw something like security +2 myQ. I went to myQ documentation but there was nothing about +1/+2 protocols. I’m EE, not a software person, so I don’t know too much about security protocols (would like to learn more)

1 Like