433 MHz no longer works after updating to firmware version 0.82.3

I’m from Germany and just updated my Flipper to firmware version 0.82.3. Suddenly I get the message “Transmission on this frequency is restricted in your region” for a saved 433 MHz capture which worked perfectly fine before. 433 MHz is an allowed band in Germany.

There is limitations in firmware (firmware/targets/f7/furi_hal/furi_hal_region.c)
I dont know why.
You could patch the firmware or use non-official firmware at your own risk.

const FuriHalRegion furi_hal_region_eu_ru = {
.country_code = “EU”,
.bands_count = 2,
.bands = {
.start = 433050000,
.end = 434790000,
.power_limit = 12,
.duty_cycle = 50,
.start = 868150000,
.end = 868550000,
.power_limit = 12,
.duty_cycle = 50,

But that there says that those frequencies should WORK and not that they’re restricted.

1 Like

Out of curiosity have you verified your region setting didn’t get messed up?

1 Like

Now that you mention it: It says R01:-- in the device info page. Normally there should also be an ISO country code (like “DE” in my case), right?

How do I fix this?

1 Like

I’m having the same issue after updating - the region just says two dashes --. It definitely worked before the update.

1 Like

If region isn’t set the Flipper doesn’t know what frequencies it can transmit on. This seems to be a recent bug. The region is set during the firmware update. You may want to update your firmware to the release candidate then back to the normal version. I would try using a different method to do the update from whatever method you used previously.

Updating via https://lab.flipper.net/ worked for me. Previously, i updated via the iOS app via Bluetooth, so i suppose that might be broken :slight_smile:


Thank you, this fixed the problem. After updating the firmware to version 0.83.1 via lab.flipper.net the region now correctly says R01:DE and I can transmit on 433 MHz again.


I had the exact same issue. I updated from IOS to 0.82.3 and lost my regional settings. I did a new update from https://lab.flipper.net/, and now everything works as intended.

1 Like

Am I starting to see a pattern? I think this may be a bug caused by IOS permission settings and location. Has anyone tried turning off the “screen time” feature? Another person had Bluetooth issues relating to it.

Because flipper owners don’t want there product banned from country I think there play by that countries communication laws

Turn off location mAybe I’m kinda of scared to try to flash my flipper hearing things like people would flash there flipper then it don’t work at all any longer not in all cases I’m not sure exactly what to do

1 Like

I understand your concern but it’s pretty safe to flash the firmware as long as you don’t try to change the radio stack yourself.

As to the issue in this thread I believe the IOS bug was fixed. The work around was pretty simple though. Just flash the Flipper again with anything but IOS to fix the missing region.

Being ignorant and careless, updating it to orginal FW with qflipper on vpn i also managed to change my region to the other side of the continent by accident and managed to break my regional setting so restoring FW on a normal connection seems like a good sollution :slight_smile: I did not expect it to look at network source and before i realized that was the cause restored it 3 times before i got the hint and i was being stupid.

1 Like