Cannot format SD card / cannot detect SD card

qFlipper-20220730-133927.txt (21.6 KB)


I am unable to mount the SD card. Following the instructions, I tried to format the SD card, but “cannot format SD card, internal error” appeared.

I have bought a new 32G SD card, so SD card should be working.

I did a search for related topics in this forum, unable to see any related to my error message.

Please advise on what I can do.

Thank you in advance.

I have attached logs for reference.

I had the same issue, then I did a factory reset and SD card was working,


I have installed a Sandisk (32Gb) used before on a Gopro, and works fine. Try to format it on a pc.

1 Like

I tried to format the SD card on pc and did a factory reset on flipper.

Still the same error.

What brand SD card are you using?

Toshiba exceria

Oh, we have no data on if those cards work with the flipper or not. Can you try using another one? SanDisk cards are known good ones.

I bought a new scandisk SD card and it worked. Thank you.

1 Like

Hi, What are the recommend sd cards for flipper?

I mean brand, V10,V60, etc.

Any SanDisk card


I had the same issue. Format did not work with any of my sd cards.
Reset to factory settings.
And all is working well now


i have a sandisk card, and experiencing the same thing. It cant format my SD card or doesn’t even pick it up. And have already factory reset me device and that doesn’t work. Any help??

Same issue. It seems do be randomic. Sometimes the SD is detected, other times not.
For example I cannot do an upgrade of the firmware, because each time is rebooted the SD is not detected…

nothing seems to help, maybe is a non-functioning lot

I also have same issue with sd card not mounting but I believe it is because of sd port on flipper was sent to me damaged is there any way to fix this

1 Like

What steps have you taken to diagnose the problem?

I have tried different sd cards ,factory resetting flipper ,formatting sd cards on pc with correct firmware , and I have checked that the sd cards all work with my pc but not the flipper so that’s why I believe it was sent to me with damaged sd card port on flipper

I’m not sure what you mean by “with correct firmware”. Did you format the SD card as FAT32 when you formatted it in the PC?

Formatted as exfat. when I say correct firmware I mean sandisk formatting firmware

I think I understand now. You used Sandisk software to format the SD card to exfat. There’s a subtle difference between software and firmware but it’s important. I’ll link below in case you are curious. If you haven’t got this resolved I believe it would be best for you to start a new topic. If this is a defect they will probably ask you to upload a video demonstrating the defect.

1 Like

I had same issue with povee V30 128 gb card. Inserted slower, older sandisk 64gb and Dolphin recognized it

1 Like