Cannot save scanned code with Flipper Zero-

On picture 1 I capture the signal:

On picture 2 I should have the option to send or save but it’s not here:

Does someone has an idea of what it can come from?
I have SD card inside, firmare update .

1 Like

That remote appears to have a rolling code. For security reasons emulation is disabled. They might also have disabled saving of rolling codes in the last firmware update. I haven’t tried that release yet. The problem with rolling codes is they change and expired rolling codes can break devices. I help many people fix their cars before Flipper disabled this feature.

1 Like

thank you for the reply. I heard about the rolling code for cars and to be careful with it, but this is not for a car it’s for my garage door.

Something I found: the free space on the flipper appears very low, although i have formated the SD card inside.
please see the attached screen of the section “About Internal Storage”:

While the menu called “About SD card” shows this:

Could be the reason why I cant save ? Or should it return a message about missing storage space?

Many garages also do rolling codes including yours according to what I looked up. There does appear to be something wrong with your SD card though and it’s possible that’s your problem. Let’s do some troubleshooting. Stop at whatever step works. If your SD card is not functioning I have to ask: Did you update the firmware on your Flipper after you received it? Please install the latest update if you haven’t done so. Usually a faulty SD card would prevent a firmware update. If you can’t update try step 3 then attempt the update again.

  1. Turn off your Flipper then remove the SD card. Put it back in and start the Flipper.
  2. Try formatting the SD card using the Flippers built in format tool.
  3. Take the card out and format it in Fat 32 with a computer. Put it back in the Flipper.
  4. Try a different SD card.

Let us know if any of this worked. If not please give us a picture of the SD card and let us know where you got it.

Once you do figure out the SD card issue see if you can add your garage remote manually. I believe Nice Flo is an option but I can’t check right now.
sub GHz >> Add Manually >> Nice Flo Select 12 or 24 bit.

I formatted the SD card with the computer (not a fast format, but complete), then put it back and update the firmware: version 0.77.1
Problem is the same with the internal storage, and not possible to store the scan consequently.
Here is the SD card i’m using:

I didn’t try to add manually for now.

Here is the flipper software screen:

FYI I can save NFC card to the flipper. Can someone show me what should be the screen like of the section “About internal SD card”? please

1 Like

When I looked at your screenshots I must have made a mistake. They both look perfect. The Flipper isn’t supposed to have a lot of memory. That’s why it has an SD card slot.

Your “About SD card” screen looks the same as mine accept mine says “EXFAT” and my card is a different size. The space on your card looks correct for an 8GB card. Visually your SD card looks legitimate and of good quality. The fact you successfully updated and can save NFC tells me your SD card is working properly. I’m reasonably sure you are running into a rolling code firmware restriction.

Why do you want to save a rolling code? You can’t use it for anything practical. The correct process is to “Add Manually” and pair your Flipper to your garage as a new remote. That way it won’t mess up your current remote.

This doesn’t have anything to do with SD card …

Flipper official firmware doesn’t support sending/saving dynamic/rolling codes, and you have the padlock on the screen meaning you have a rolling code …

1 Like

That’s very useful. I didn’t know the padlock meant it’s a rolling code.

This is in the docs.

1 Like

I just encountered this today.
Have a garage Tx I’ve previously copied and used (my normal Tx is always in the car).

But now when I try to copy my key again I get the padlock.
Is there any way to get around this so I can save it anyway? I really don’t think the rolling code is neccessary as I was able to use my FlipperZero before to do just this.

Sounds like you may have have updated the official flipper firmware since you first copied the code. I don’t think that’s a problem on unofficial firmware versions.

1 Like

You are absolutely correct. Will remember to avoid update button in the mobile app

Nice FloR-S is easy to play with…
If your FW version does allow you to create a new NiceFloR-S remote with a new serial or if you have something like one of those cheap chinese scimagic self learfning remotes for rolling codes you can generate a new FloR-S remote with a new serial number and pair that to your reciever using an already programmed/working remote without opening the reciever…