Device not turning on

I ordered my Device (NVEN3E3P) from Joom and can‘t get the device to start up. I wrote with the support from Joom and they directed me to this forum for help.

I don‘t really have something to attach as a pic with a shut off device won‘t really say much and a video is not possible to attach.

Do you have any idea why it won‘t start up and maybe some tips what I can try. I already tried starting it while it is charging and let it charge for a while. I also tried starting it with the two button combination.


1 Like

Hello! You can attach a video by compressing it to a .zip archive beforehand.

Can you please do the steps from Firmware recovery - Flipper Zero — Documentation and recond a video of it? Please make sure that you’re connecting your Flipper to your PC directly, without any hubs or adapters, as they are known to cause issues.

Hi, I tried these steps and nothing happend. The Device didn‘t give any response and the display didn‘t turn on. The computer didn‘t recognize any device attached over usb. I think the device is simply not working.

I could attach a video if you wan‘t but it won‘t be very useful I think because it would just be the device with a blank screen.

As Joom would like that I still upload the videos here are the videos showing how I tried the different resetting methods and how I connected the device to my notebook and it didn’t get recognized. I had to upload them to Google Drive as I wasn’t able to upload a .zip because I got an error. The videos are in the link attached.

Thanks for your help.

Yes, this looks like a hardware faliure.

Please contact [email protected] for further assistance.

1 Like

This topic was automatically closed after 6 days. New replies are no longer allowed.