Does not connect to windows or mac


Since last week the usb port of my xxx only works for me to load it, qFlipper does not recognize that it has been connected, I have tried both windows and mac and also in the web version.

I managed to update it via mobile app but the usb still does not work

PD: I have tested with several data transfer cables

PD2: Sorry for my bad English


Unplug the Flipper and try a “Reboot with hotkeys”. That can solve many issues.

1 Like

anyone solved this issue?
my flipper suddenly stopped connecting USB on macbook m2. it worked just fine a week ago, and nothing changed…

i tried dfu, restore ofw, hardrestart, etc…
nothing works.


hey i just discovered it’s the physical USB-C connection that’s faulty. not sure if it’s all 3 cables i have or the usb port on flipper. will try new cables tomorrow.

1 Like

Sorry for the delay (I’ve been away for work) I tried it and nothing, it’s still the same.

I’ve tried with several cables and on several pc’s (I think it’s the flipper’s own usb-c).

I have the same problem. Nevers had any problems with qflipper or webinstallers.
But now as soon as I connect the usbc cable, the battery charges, but the flipper gives no response in my computer system not in qflipper or webinstall

And i think you are right. That something is wrong with flippers own usbc connection.
If i carefully push the cable a little harder and to right to the gpio pins, qflipper response very short and then crashes that it could not make a connection

1 Like

That could be a malfunctioning port. I’ve found sometimes using a new cable will make the connection properly if a port is worn or damaged.

I have already tried several cables on different computers, also different operating systems. But so far no difference

I was able to remove the problem by plug the cable in the flipper with quite a bit of force. So im sure the usbc in the flipper is not doing so well

If you hold back and middle for 30 seconds, does it get recognized in DFU mode? Not saying it is a physical cable problem, but i have seen some driver sets be a bit picky with communication port sharing etc if the cable is verified not cause the issue. for win users netsh winsock reset might help in some configurations,or swapping chipset drivers to more recent or previous versions for some tablets. but if the connection works, and you can get it into DFU before connecting, maybe that helps working around it? then flash it with new version and see if it gets detected and the repair option works? But if it is multiple operating systems giving problems i would almost think about a physical issue from usb connection for example.