EU Frequencies not fully supported, how to adjust/fine tune the frequencies

Hi, i am from EU (Austria) and i found out, that i can’t get the exact frequencies that i need to eg. unlock my own car.

My car is a old 2003 Seat ibiza 6L and has no rolling keys etc. The Car operates on a officially supported frequency but i am not able to set the exact frequency i need, so i wanted to know how we can adjust flipper to allow a smoother jump between frequencies?

In my case i did an exact analyze of my car key and it would be exactly 434.409 AM Modulation but the i can only set the flipper to 434.42 and next freq would be 434.77 so as those are both way off as the freq needs to be really close because they are super sensitive, i can’t get my flipper on the correct frequency.

I was able to lock my car 1 time after about 100 tries but i was never again able to do it as i am way to far away.

I changed the setting_user file in my subghz/asset folder and added the needed frequency and also added it to the hop frequencies but i am not able to select my new and needed one so it seems my changes got ignored.

It would be great to ether have an option to manually enter the exact freq or give us the option to have a more sensitive setting to set them maybe in 100 hz steps. (inside the supported freqs by the chip)

Maybe US freqs are more strict but in the EU we have ranges where everyone can operate on and so our remotes can slightly go off the freq it should be.

Any way we can get our own frequencies in or a way in the future for a better fine tuning the frequencies?



Hi! The frequencies from the user file are added to the end of the list, have you checked there? The idea you’re describing is the same thing that we’ve done using that file

Changing frequencies in such small steps would be a bad UX choice (you’ll have to click through A LOT to get to the one you need), so we won’t do that, sorry.

I just added it exactly between all the other frequencies in that file but in the selection of the flipper it isn’t showing up


I’m still waiting for my flipper, but maybe it’s “case sensitive”.
You have here the “F” in “frequency” large, try it with a small “f” and see if the frequency is taken over.
best regards


omg i will try it, would be cool if this would do the trick :smile:

You were right, this is really case sensitive, i was just copying the same line from the frequency analyzer file, so i did’t think of that as in that file all Frequencies are with a uppercase F so i just copied this to the setting_user file. Thanks for this hint, i haven’t recorgnized that :smile:


Glad if I could help you.
Does it work with your car now?

yes it does :slight_smile:

1 Like

Hi dude, kann ich dir per PM paar Fragen stellen. Hab das gleiche Problem und bekomme es einfach nicht hin…


Wouldn’t it be more simple if from the frequency analyzer user could directly add the detected frequency to the frequencies listened by Flipper?
At the moment, frequency analyzer shows frequency and… that’s all. No use of this information. And the shown frequency vanishes after a few seconds.
Suggestion: when frequency is detected, then add an option “Add to frequencies list”.
Is it possible?

no, it does not make sense, the frequency analyzer does not scan the entire range, but switches over the already added frequencies and looks at which frequency is the strongest signal, and if it displays it, then the desired frequency is already in the list

I would recommend adding the ability to type in a frequency. If I know that someone is using a specific frequency for something, I’d like to be able to use my flipper at that frequency, given it’s within the proper allowed range.

1 Like

Just type that to your settings file ?

1 Like

Is there a fast and convenient way to do that? Flipper doesn’t seem to have a text editor, and the app won’t let me change that file.

There’s a big difference between taking a moment to type in a frequency I just discovered a device using vs. lugging around a laptop so I can pull it out just to edit a settings file every once in a while.

I have the same car, Ibiza 6L 2007 imported from Italy and it worked for me with the stock frequency. I used the read raw function though. I have just bought my Flipper in the end of 2022, don’t know if there were some upgrades. Were you using the Read RAW or you are trying to decode the sigan?