Failed to parse update information: ChannelInfo: Expected an array of versions

Brand new flipper just arrived, currently on firmware 0.60.3

I have tried update via mobile app and MacOS. Mobile app shows blank for update channel.

On Mac, I get: Failed to parse update information: ChannelInfo: Expected an array of versions

The JSON at the URL looks sane, and has a “channels” array.

I even tried downloading some of the tgz files and doing update from file, and qFlipper just crashes.

I really hope I am just doing something stupid here, but any tips appreciated.

Yes, I searched for that error first, so sorry if a topic already covered.

1 Like

This was broken for quite a while.
I have tried again and it is now updating.


what did you do to fix this??

yea im currently getting this same issue. Im wondering if their update server might be down?

Same here. Windows and iPhone app cannot resolve the server/firmware information.

hopefully this gets fixed asap
or if theres a solution plese let me know

started working again?


yep lol

All I did was wait half an hour or so.
The debug showed it was getting some json, and I was able to get that with no problem from my machines.
So not clear what the problem was exactly.

I assume their servers were down again today 12.11.22. My same exact setup worked yesterday but could not download databases on a reflashed device today. even if it was on my end, here is a work around for when qFlipper will flash latest firmware but will not update flipper zero with databases.

See you on the flip side!

had the same problem it fixed itself once i took a screen shot of the erro msg on the FZ

my just fixed itself one took a screen shot