Firmware Update problem using Archive


Whenever I try to update firmware using archive app on flipper itself it “fails” It just says:

  • Loading update manifest
  • Backing up LFS
  • Restarting

and after that nothing happens, it just restarts and doesn’t update. Even If i try and update via qFlipper the same thing happens. Update is only possible if I put device into DFU mode or if I restart for firmware update via menu in flipper.

What could be the problem?
Tried with multiple SD cards, already did factory reset.

Please see the video of me trying to update via archive app:


1 Like

I noticed this behavior also. But I tried to initiate update using qFlipper and Android App.
Finally I was able to update only manually entering in in DFU mode and pressing “Repair”. But then I lost settings and my Flipper leveling progress :slight_smile:
Old version 0.62.1, new: 0.63.3.

Yes, that’s correct. I found out that only way for me to update flipper is to enter DFU mode and update it via computer. Only other way that also works is via qFlipper app when selecting firmware from file and selecting firmware with .dfu extension.