Flipper can be charged but undetected

My flipper when plugged into my laptop can be charged but not detected at all. any tools that is USB related could not be used. i have tried rebooting and setting it to DFU mode but still cannot be detected.

is there anyway i could resolve this?

3 Likes

The last time I helped someone with this specific issue they had a bad USB cable. Check that first. A USB C cable can sometimes charge a device but not pass data. This could be because of damage or defect of manufacture.

1 Like

I used the cable that flipper issued in the box and I have tried data cable even to cables that are type C to type C, but still no use.

1 Like

Does the computer make a noise indicating it was detected?

Let’s see if it shows up in Device manager.

  • Open the “Run” dialog box by pressing and holding the Windows key, then press the R key (“Run”).
  • Type devmgmt.msc.
  • Click OK .
  • Expand "Ports (COM & LPT)

Now look to see what com ports are listed. The Flipper will be a serial port followed by “COM” and a number. If you aren’t sure whether the Flipper is there just unplug it to see if one device disappears from there then plug it back in to see if it returns.

Nope it does not make any noise to indicate that it detects a connection, but it charges the device

What OS including build number?
Have you tried it on other devices?
Have you upgraded the Flipper Firmware?

I’m using windows 11, I tried connecting other devices as well even on my android phone but it only charge. I even upgraded to the latest version but it still remains the same. I thought it was my laptop issue but I try connecting phones and usb stick to my laptop and it reads.

Did you look in device manager as I recommended?

Yupp tried that, nothing appears

It might be time for the official support team. Even if you had bad drivers something should have showed up. Maybe @Astra will chime in.

Yea, just all of sudden it stopped working.

Hello,
I’ve exactly the same problem.
suddenly, only charge is done via usb, no data link.
nothing showing up in windows when i connect usb (no sound, no change in device manager).
I tried multiple usb cable and test with a phone to see if usb data works (which it does).
Tried to reboot, tried on another pc, tried the last firmware (which i can update with bluetooth connection to the flipper).
what should i try next ?

1 Like

You could try a different PC and try a different USB port. Use a direct USB connection and don’t connect via a USB hub if possible.

You could also try DFU mode to see if it connects. I’m not sure if something could be done in DFU mode that would help get connectivity back ib regular operating mode.

as I said in my message, i’ve tried :

  • different cables (all working for data for connecting an android phone)
  • different pc (2 windows, 1 linux)
  • dfu mode
    of course everytime directly on a usb port, no hub involved

Really feels that nothing happens when i plug the usb cable (no sound, no change in device manager …)

Similar problem. Flipper, when connected to a macbook, can be charged, but is not detected.

Macbook air M1, cable from box with flipper, and original usb-c apple cable.

On MacOS Flipper is visible in the list of USB devices. The application starts connecting according to the logs, but after a minute an error appears: UNSUPPORTED DEVICE FOUND.

1 Like

That sounds like a driver error.

I’m out of troubleshooting ideas since it sounds like you tried all the proper steps.

The same problem: charging via USB, nothing happens after connecting to PC. Already tried different cables, ports, PC. All variants of reboot, DFU mode. No results.

this just started happening to me as well… only thing i have done different recently is i just reinstalled windows. but i have all my drivers for all of my hardware up to date… so what gives?? #sadface

  • Try rebooting the Flipper(“Normal Reboot”) first with the Flipper unplugged from the computer.
  • Try a different USB cable. Cables break occasionally.
  • Try a different USB port. Standard USB troubleshooting.
1 Like

Hello everybody,

So I had the same problem but I solved it.
If your comuter detect the device, it is very good.

So, just go on the device and:

  1. Settings
  2. Power
  3. Reboot

Your computer (qFlipper) will detect it and so there you go.

Good day