Flipper do not charge anymore

Hi all.

I have my flipper for 5 or 6 month now and all was fine.
But this week it fall out of battery and when trying to charge, nothing happen.
The battery led does not light on.
And the flipper does not power on of course.

The charger and the cable are ok (it’s those I usually use and they work on my phone).

Maybe the battery is ko ?
But do you know if in this case the battery light should be on anyway ?

Any hint on how I can diagnose ?

Thanks for any help.

1 Like

We just addressed a similar issue. A hard reboot solved it. See this thread. If that doesn’t help let us know.

Thanks for your reply.
I already tried to hold buttons for 30s without successs.
Is it a software or hardware procedure ? (as my flipper is totally off).

Also, do you know if the led battery should light up ?

Just because the Flipper appears to be off that doesn’t mean something isn’t happening. Did you make sure the Flipper was not plugged in while holding down the buttons? Astra says it will “physically disconnect and reconnect the power circuit” so I would say it’s a hardware procedure.

You can also hold just the BACK button for 30s, that will cause a hard-reboot (physically disconnect and reconnect the power circuit). The Flipper also has to be unplugged to perform this.

My experience with battery powered devices suggests you might not always see a charge light immediately after plugging in a device. After resetting plug it back in a leave it for a while.

You should of courser verify the cable and chargers are still functional. Come back and let us know if this gets you running again.

Ok, I’m not at home so I asked my son to retry the procedure and … it works !
I’ll ask him first next time :).
My device is back !.

Thanks a lot for your replies and sorry for the duplicate issue.

1 Like

Glad to hear it!