Flipper no longer recognised as a USB serial device - No /dev/tty* or lsusb results in normal, DFU or Recovery modes, tried multiple cables & computers

I’ve been in love with my Flipper Zero for a very long time but have had to leave it unused for the past two weeks. I picked it up tonight to explore some of the new applications before continuing work on my application (Gravity), to find that it is no longer recognised by either of my computers.
There is no TTY device listed representing the device when it is connected (ls /dev/tty* - Normally appearing as ttyACM0), and no entry in the output of lsusb for the device.
I’ve tried 3 different cables, and also confirmed that the cables work by connecting my phone and using adb.
I’ve tried 2 different computers - Linux and MacOS.
I’ve tried in standard device mode, DFU mode and (I think) Recovery mode (after holding back and left for 30 seconds).
I’ve tried reinstalling several different firmware versions by manually installing them from the Flipper browser.

As you’d expect neither qFlipper or fbt are able to recognise the device.

Is anyone able to please please please help?

Damn that sucks? Any luck? I would reach out to the dev team as homefully this isn’t some internal RTC bug or something (do I sound like I know what I’m talking about yet?