Flipper only powers on with USB power

Hey, stoked to get my flipper today but am running into a minor issue in that the back button doesn’t seem to power the flipper on. Things I’ve tried:

  • Charging for 2+ hours
  • Factory reset/reflash. Running 0.58.1
  • Trying restart instead of holding the back-button for 3 seconds

Things that worked, but only temporarily

  • Held the o + back button for almost 30 seconds trying to do a hardware reset and it popped on without usb power. Checked the battery during that period and it registered as fully charged. As soon as I plugged it into usb and then unplugged it, it died again.

Anyone ever experience this before and/or have a resolution? I may crack the thing open next and do some voltage testing on the battery leads to see if there’s some problem there. Any advice appreciated!


I am having the exact same issue in all regards. It works flawlessly under USB power. But never works under battery. Also mine is showing this “dash” mark in the battery icon that I can’t find anywhere else in doco. Hope there’s an easy fix!


I’ve tried to recreate this by locking mine, powering off, and connecting and disconnecting via USB. It looks like there is a dash instead of the fully battery bar midway through start-up from OFF. Maybe there is an issue with booting up? It looks like you’ve checked out the power menu already, what was the health status at? What was the power draw? Mine shows 12 mA with the backlight on and 8 mA with the backlight off. Do you have any extra programs @Derry you said you already tried to re-flash, which was my last suggestion. The good news is if the battery is kaput it looks like it is relatively easy swap out. Part of the design was to include a modular replaceable battery. If there is a test you would like me to try to run, or a power state you would like me to recreate on mine I would be happy to help. Good Luck!

1 Like

I have the same issue as @Derry. The device is on when I plug in usb cable. When I unplug it, it turns off. Hold back button for 3 sec doesn’t work. The battery is shown as dash.
Any ideas?

I just got mine, I’m having a similar problem but even the 30 second hold didn’t do anything. I really wish i knew what was wrong with it. I let it charge for +2 hours, updated the firmware, tried restart, power off, reflashing, etc.

Mine also has the - through the battery instead of a solid black battery. On the battery health page it says 100% charge, 27c 4.3v 100% health

My stats are the same for power status. As @UPN

If you have a dash instead of a full battery - please contact [email protected] and tell them about your problem.

1 Like

Alternatively, you can follow this guide and try to fix the issue yourself


Hello, I received my Flipper today and I also had this issue.

It had powered on out of the box with battery when I initially received it. But after plugging it into my computer and updating the firmware, the battery showed the “dash” symbol and would only turn on when connected to USB power.

I was able to resolve this issue without opening it up as @Astra suggested by trying a few things.
I’m not sure which one of these things did the trick, but here is what I recall doing in the order that I remember doing it.

  1. Reinstalled the current firmware using the “Reinstall” button.
  2. Changed the “Firmware Update Channel” from “Release” to “Release-Candidate” then clicked “Update”.
  3. Changed the “Firmware Update Channel” back to “Release” then clicked “Update”.

When it booted back up after doing number 3, it had the normal battery icon and worked without USB power.
So maybe just keep updating/reinstalling the firmware until it starts working??

Hope this helps someone!


Thanks @Astra, the steps from the guide helped me to fix battery issue. Something wrong with connection.

Glad to hear this! Also, can you please tell me what batch your wave was in? Or if you don’t know, can you please PM me the serial number and your dolphin’s name? We want do find the cause of this issue and need to collect as much data as possible

I’m having a battery issue similar to this, but there is no power even when plugged in. I had the Flipper powered up when it arrived earlier in the month, but haven’t gotten to sit down and use it until yesterday. I’ll try the guide first, but need to order the tools for it first. Is there a site that delivers to the US that’s not Amazon? Any recommendations?

Try ifixit.com

Please contact [email protected]

What type of battery does the Flipper Zero take? The ground lead on the battery has an intermittent open. Also, what is the procedure for replacement of the battery?

It works for me