Flipper stuck in DFU mode


Firstly I want to say that I really love my Flipper!
But I have a problem with my Flipper.
It got stuck, and I did some key presses on it, and it entered the Update & Recovery Mode DFU Started.
I followed all the steps in https://docs.flipperzero.one/basics/firmware-update/firmware-recovery
But it reboots and always comes to the screen “Update & Recovery Mode DFU Started” again.

I tried on 2 computers. 2 different USB C cables and even 3 different versions from qflipper…

Can you help me please fix my flipper? :cry:
(I already sent an email to support and Zoë advised me to create a topic on the forum, so that the devs could help)

qFlipper-20220811-220233.txt (19.9 KB)

I was browsing the forum and I found my solution!

However, you may try this manual procedure to get your Flipper working:

  1. Switch your Flipper to DFU mode and connect it to the computer.
  2. Right click on the DFU in FS Mode → select Update driver (Fig. 1)
  3. Select Browse my computer for drivers → Let me pick from a list of available drivers
  4. Select Universal serial bus devices → WinUsb device → WinUsb device (Fig. 2-3)
  5. Click Next and Yes

image (1)
Fig. 1

image (2)
Fig. 2

Fig. 3

It happened again… And now it has the same issue al over again, I have the same driver as mentioned above…

I tried it with 3 different drivers… Still stuck in DFU mode

2022-08-14 16_04_51-DFU in FS Mode Properties
2022-08-14 16_01_13-DFU in FS Mode Properties
2022-08-14 16_00_53-DFU in FS Mode Properties

STM32_Driver.zip (4.6 MB)

This seems to be the correct driver, now it worked with this one

2022-08-15 10_28_58-DFU in FS Mode Properties

about an hour later, and it happened again. I really think my flipper is broken :frowning:

That sounds like a faulty USB connection. Are you using any hubs or adapters? If so, please connect the flipper directly to your pc’s motherboard USB ports or your laptop’s USB ports

I’ve managed to fix it 3 times already. But the flipper is just frozen. And when you press the back Button af few times it reboots into DFU mode. And you need to repair it.
Now it is working again. But for how long… :crossed_fingers:

This is how it is all starting:

1 Like

That looks like a faulty component in the button assembly. Please contact [email protected] and send them a link to this thread.

1 Like

i hace same problem please help

For me it was a stuck key, not a driver issue.
So it had to be replaced.


< + (return)
press and hold < and press (return) that takes you back to home

1 Like

I had the same stuck in DFU (must have pressed wrong buttons in my pocket).
Hold the power button. It took about 20 seconds I nearly gave up!
It then turned off and peered on normally.

That’s fine. Fast reset combo is holding Back+Left, 3sec is enough. Just holding Back is a secondary option, it is less reliable and takes longer.

I have the exact same problem. It remains stuck in DFU mode and I cannot figure it out.