Flipper will not Read my HID RFID Cards

I’m on RC 0.66 and I’m still not able to scan my HID RFID cards. Are there certain types of HID cards that are not yet supported?

No, all 125khz HID cards should be supported

1 Like

I’m trying to read a HID iClass DL RFID card but it’s not reading. I tried three cards that all worked on regular scanners, but none of them worked on my flipper.

Any chance I missed something? Are they encrypted or something? (I don’t know anything about how RFID cards work so I’m just guessing)

Update: I think I found the issue that the cards I was using are 13.56 MHz, not 125kHz. According to the HID page here: https://www.hidglobal.com/sites/default/files/hid-understanding_card_data_formats-wp-en.pdf The 125kHz and 13.56MHz cards are designed to work seamlessly.

I assume that means that if I can manually enter the keycard data for the HID H10301 card, it should work. Right?

I don’t know how I would enter this:

Into my Flipper since it says to “Enter the data in hex”.

Also is 13.56MHz RFID support planned?

13.56 MHz is just NFC. Switch to that mode and try again?

No luck. I tried the NFC functions but they don’t work. Tried again with RFID but still no luck.

Can you help me with putting in the data manually?

Those cards are 100% NFC. Try updating the firmware? There’s also unofficial firmwares out there with extra features.

But, some NFC access cards have secure elements in them (authentication) that are baked-in in the factory and can’t be reproduced. You could emulate their UID on the Flipper, but just a UOD may not be enough. And even though you can emulate the UID there, that doesn’t mean you’ll be able to write it to any card. I have full confidence the Flipper Zero can read whatever cards you have if they’re 13.56 MHz. But if they are, 125 KHz (RFID) working is not an appropriate expectation.

If you’re saying you can’t read it, you shouldn’t expect to be able to write.

It looks like iClass cards aren’t able to be read yet: https://forum.flipperzero.one/t/13-56-mhz-hid-iclass-corp1000-wiegand-format-cards/1990/5

Seems like there’s a command to manually enable it, but I can’t seem to figure it out.

You can read iClass cards using the picopass app in the latest RC firmware.


Thanks! I’ll try it out.

The picopass app reads it now, but it can’t emulate. How do I do that?

Also, I see an option to write, but what cards should I buy to successfully write to it? All the places I can find to buy iClass cards ask for a facility code and ID which I don’t have.


Could you please point it out?
i.e. " github in the lfrfid-overhaul branch)"

I tried the search here:

Update to the latest firmware :

If picopass is not included on the official dev/updated you can use this one compiled for official firmware.

Yea Keysy can be covenant for some older basic ones I find. What about the PicoPass reader?

Hi, I can’t read my HID card, but can read the raw data. How can I analyze and implement it? Can I send it to you?

I have a RFID that it can’t read/save however can get the raw data, how do I extract and send the data

I have an interesting issue with HID cards . A co-working brought their flipper into the office one day and we noticed that their flipper could read our work HID cards no problem but mine won’t. When scanned their flipper reads the work card as HIDProx[Generic} 37-bit HID Proximity. We went through the settings section on our respective flippers and both are MOdel Fz.1 HW Version 12.F7B9c6 FW Version 0.77 with all other configuration settings identical. Yet for some reason theirs can read these cards but mine can’t.
The only difference that I can come up with is that mine was an original kick starter pre-order and they picked one up reacently from the last batch that was released.

Any thoughts on what could cause this discrepancy in functionality?

I have a RAW Read, where can I submit my dump? Where is it stored on the card folder structure?

Hello guys, it’s been almost a year. Do you know if this is already been patched? I’ve also been wanting to have access to my work place with my flipper.