Flipper Zero Black not charging, tried to fix it, made it worse

Hello there. I got my Flipper Zero (the black one) from kickstarter, and didn’t have the time to play with it for months. When I decided to start messing around, I noticed it would take forever to fully charge (either via PC or using a turbo wall charger), 2 or 3 days with the flipper connected to the charger some 8 hours a day.
I thought maybe it was a firmware thing (stock, updated, custom), but no luck.
Now it simply won’t charge or turn on. I tried the LEFT+RETURN for 15 seconds, tried RETURN for 30, both connected and disconnected. I searched the forum and found someone saying that disconnecting the battery and connecting it again solved their problem, so i tried opening the Flipper using the iFixit guide.
I got the 4 long screws out,removed the back casing, but when trying to remove the 2 short philips screws, one of them stripped (though I didn’t even used much force). Now I can’t get to the battery connector without risking breaking the Flipper (and I don’t have experience with such tiny screws being stripped). What can I do?

Edit: There’s the little rascal. As you can see, I tried cutting some little pieces from a rubber band to try and get it out, to no avail

1 Like

I feel your pain. I stripped some tiny torx screws in a phone once. The rubber band trick does work on bigger screws but I had no luck on the small ones. This is a bit risky but it did work for me on the little torx screws. Superglue! You must be EXTREMELY judicious with superglue. Afterwards it can be removed with nail polish remover to separate the driver from the screw.

1 Like

Ohh, that’s bad…
You need a PH0 driver for those screws to avoid stripping them, and from the looks of it, it may still be removable with a proper driver.

If that (and other methods) didn’t help, your last option is to get a small drill bit and drill through that screw’s cap, detaching it from the screw base. You’ll loose one screw point (as the base will still be stuck in the case), but at least you’ll be able to remove the board, reconnect the battery, and assemble it back. Loosing that one screw shouldn’t be too bad as the case will also apply the needed pressure, but the buttons may become a bit more mushy due to that.


Hey guys! I tried super glue and failed, and couldn’t find a drill bit fine enough to remove the screw cap, so I ended up just slowly prying it open. I disconnected and reconnected the battery, but to no avail. It still won’t charge. Is my device dead? Can I send it for repairs? :worried:

1 Like