Flipper zero does not work from the first day

Hello, I bought the zero flipper on Joom order number QQ4NWNGN

When it arrived it did not turn on, I charged it, I pressed the buttons that told me the flipper support, I have tried combinations, I have tried holding the button for 30s to reset it but it does nothing. I’ve tried everything and I can’t fix it. The box arrived in good condition with small bumps but the flipper seems to be physically fine although it does not turn on or do anything, no lights or sounds or anything at all. What I can do?
Thank you

Hello! Please record a video of doing the following actions:

  • Disconnect the USB cable if it’s connected
  • Press and hold the BACK button for 35 seconds
  • Connect the USB cable back to the device

If this didn’t help, please upload the video to any cloud storage (google drive, dropbox, etc.) and post a link to it here.
I understand that you’ve already tried doing this, but we need the video to confirm that the device is indeed broken.

1 Like

Hello, I have uploaded several videos on Streamable.
I pass all the videos that I have been recording to show it to support.

Hello, I’ve taken a look at your videos, and none of them follow the steps I listed in the previous post. The hard-reboot sequence does not work when a USB cable is attached, so please perform it with the cable disconnected from the device.

  • Disconnect the USB cable
  • Press and hold the BACK button for 35 seconds. (No other buttons should be pressed at that time). If your finger slipped before the 35-second mark, you’ll have to do it again, as the sequence is triggered only by continuous holding of the button.
  • After 35 seconds, release the BACK button
  • Plug the USB cable back in
  • Hold the BACK button for 5s to turn on the device.

Please record a video of following these exact steps, without deviating from them.

1 Like

I just recorded and uploaded the video. I think I have done everything you have asked. Greetings

1 Like

You are holding both the BACK and the LEFT buttons. This won’t work, as that combination doesn’t trigger a proper reset. Please hold only the BACK button (the one with a curved arrow on it).


I uploaded the video you asked me

1 Like

Hi, sorry for the late reply. Yes, I can see now that your device really is broken, please contact [email protected] for further actions. Please include a link to this page in your email.

1 Like

This topic was automatically closed after 31 hours. New replies are no longer allowed.