Flipper zero recovery mode (dfu) doesn't work

Hi guys,

My flipper zero just turned itself off and won’t turn on, I’ve already tried to recover it

  • Unplug Flipper Zero from the USB. If you do not disconnect the device from the power supply, the DFU mode will not activate.

  • Press and hold the OK + BACK buttons for 30 seconds. Then release them. If the firmware is corrupted, there will be no indication on the screen—this is normal.

  • Connect the device to the computer. Flipper Zero should be detected as a DFU in FS Mode.

but nothing happens.
I thank you in advance for your help


It’s possible the Flipper got into some type of loop where it drained the battery.

I would do the “normal reboot” procedure with the Flipper disconnected from USB.
Then I would plug it in to charge for several hours.
Finally I would attempt to turn it on again.

If that doesn’t work retry the DFU process.


Hello, I have the same problem.

I have the FlipperZero in recovery mode (DFU) qFlipper application window closes and my FlipperZero is completely dead. (run’s on Linux 5.4.0-135-generic #152~18.04.2-Ubuntu SMP Tue Nov 29 08:23:49 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux)

the log of the process:

Blockquote 581 [APP] qFlipper version 1.3.0 commit 01fcfec9 2023-03-27T11:51:38
582 [APP] OS info: KDE Flatpak runtime 5.15-21.08 5.4.0-135-generic Qt 6.4.3
583 [REG] Detected new device: VID_0x483:PID_0xdf11
630 [DBG] Device reported transfer size: 1024
630 [DBG] Bytes uploaded: 32 100%
630 [DBG] Upload has finished.
631 [REG] Registering the device
631 [BKD] Current device changed to “Oloqiade”
800 [UPD] Fetched update information from https://update.flipperzero.one/firmware/directory.json
9605 [UPD] Fetched update information from https://update.flipperzero.one/firmware/directory.json
9633 [DEV] Full Repair @Oloqiade START
10574 [ZIP] Uncompressing file with size of 165049 bytes…
10592 [ZIP] Uncompression finished : No Error
11142 [ZIP] Uncompressing file with size of 197486 bytes…
11156 [ZIP] Uncompression finished : No Error
11995 [RCY] Set Recovery boot mode @Oloqiade START
11999 [DBG] Device is not idle, resetting…
12027 [DBG] Device reported transfer size: 1024
12028 [DBG] Bytes uploaded: 128 100%
12028 [DBG] Upload has finished.
12028 [DBG] vvv ATTENTION: Ignore errors below until matching closing message. vvv
12028 [DBG] Device is not idle, resetting…
12055 [DBG] Device reported transfer size: 1024
13335 [DBG] Failed to perform control transfer: LIBUSB_ERROR_NO_DEVICE
13336 [DBG] Unable to get device status
13336 [DBG] An error has occurred during download phase
13336 [DBG] ^^^ ATTENTION: Ignore errors above until matching opening message. ^^^
13336 [DBG] vvv ATTENTION: Ignore errors below until matching closing message. vvv
13336 [DBG] Failed to release interface: LIBUSB_ERROR_NO_DEVICE
13336 [DBG] ^^^ ATTENTION: Ignore errors above until matching opening message. ^^^
32298 [default] QStandardPaths: wrong permissions on runtime directory /run/user/1000, 0755 instead of 0700
43526 [RCY] Timeout with an online device, assuming it is still functional
43537 [RCY] Set Recovery boot mode @Oloqiade SUCCESS
43543 [RCY] Co-Processor Firmware Download @Oloqiade START
43555 [DBG] Unable to open device: LIBUSB_ERROR_NO_DEVICE
43556 [RCY] Co-Processor Firmware Download @Oloqiade ERROR: Can’t start FUS: Failed to initiate transaction.
43557 [DEF] “Co-Processor Firmware Download @Oloqiade” failed with reason: “Can’t start FUS: Failed to initiate transaction.” Attempting to install the firmware anyway…
43568 [RCY] Firmware Download @Oloqiade START
43626 [REG] Device went offline: VID_0x483:PID_0xdf11

Then I tried again to activate the FlipperZero with normal reboot and with recovery mode. The device reconnects to qFlipper but the repair process crashes again.

It seems to be an interruption of the USB connection (see “LIBUSB_ERROR_NO_DEVICE” in the log file) - BUT I have to ignore errors until matching opening message. I see no opening message, qFlipper terminate and FlipperZero it’s still dead.

And now? what next?

1 Like

I see a permission error in there too. Don’t change those permissions now but did you change permissions for that directory before running Qflipper?

thank you for your quick response. I don’t see any reasonable correlation between the permissions and the termination.

In particular, 0755 means that Group and All can also read and execute in the directory, instead of 0700 meaning that only I can read, write and execute in the directory.

I interpret the message only as an indication that more permissions are possible in the directory than necessary.

That’s what I thought too but that’s a special directory in Linux so I figured maybe there’s something I missed. It makes sense only the user would have permissions(0700) in that directory from a security standpoint but I don’t see why excess permission(0755) would cause an error either. That doesn’t mean it isn’t significant though. I found a case where that error was determined to be a bug in the application(not qFlipper specific) when I Googled the error.

Some programs (I personally caught OpenSSHd doing it) specifically check perms on their crypto data. E.g. host private keys are not readable by anyone except for sshd, user’s authorized_keys is writable only for that user etc.
Perhaps some library qFlipper uses got into that habit too?

That’s pretty much what I was thinking. The logs say the log level is “default”. That doesn’t sound like a high error level.

I just got an update for qFlipper on Windows @pipkin you should see if there is a Linux update. Maybe you get lucky and the problem was fixed. I agree there seems to be a serial issue from the logs but that may be a symptom of the root issue. It seems like every time I have an issue on Linux it comes back to permissions as the root cause. That’s probably why permissions jumped out to me.

thank you for your quick response.

I’ve tried this suggestion, unfortunately it didn’t work.
Thanks anyway.

I let the device rest for several days because I thought the battery was deeply discharged
but nothing has changed in the situation

What I forgot to say, I’m using Windows 11

1 Like

There is no new update for Linux. The message about wrong permissions does not appear in the log when trying again.

Is there a reference implementation - maybe even a VM image - of Linux with qFlipper known? This always helps to find errors in the interaction of software like qFlipper, operating system and kernel.

1 Like

Did you get this figured out? I saw a reference to Linux Mint working.