FlipperZero won't turn on


My FZ won’t turn on again after I formated the SD Card and hit the “Repair” button on qFlipper. I’ve tried hard, normal and DFU reboot but nothing is working. When I pluged it to the cable to charge it, the led remain off.
What should I do ?


1 Like

Is it possible your battery got low?

My suggestion.

1 Disconnect from USB
2 Eject SD card
3 Reboot with hotkeys
4 Plug the Flipper in to charge for several hours. Don’t worry about lights.
5 Reboot with hotkeys
6 Attempt to power the Flipper on without the SD card.

If this helps please let me know.

1 Like

Thanks for your suggestion.

The Flipper was at 100% battery before this. I tried to let him charging but nothing works :confused:

1 Like

Hi! Please try doing full firmware recovery. If it didn’t work - please try changing your USB cable, make sure you’re not using any USB hubs or adapters, try a different port on your computer, or try using a different computer.


Thanks for your help but this doesn’t work. I think my FZ is just totally broken :man_shrugging:

1 Like

I would still try the reboot with sd card removed.

If you hold back+ok for 30 secconds it should turn up as usb device in dfu mode and you should be able to reflash it from there, if it does not work after making sure you tried different cables and or pc just to make sure it is nothing related to local restrictions on a machine.

If it is in DFU mode, qflipper should give you the repair option. but it should turn up as a USB device if you hold the buttons long enough for it to go in panic mode reboot.

Also try a different old 512mb SD card or something like that to make sure it is not crippled partitioning or storage making it fail, but so far i have not managed to break it beyond repair so i hope there is a easy fix .