Get an error when trying to flash the devboard

When I try to update the devboard firmware, I get an error
Tried to flash via wifi and via usb. Forgive me if my question is elementary.

flipperzero-firmware git:(dev) ./fbt flash_blackmagic
	APIPREP	build/f7-firmware-D/sdk_origin.i
	APIPP	build/f7-firmware-D/sdk_origin.i
	SDKCHK	firmware/targets/f7/api_symbols.csv
API version 34.1 is up to date
arm-none-eabi-gdb -ex "source ./scripts/debug/gdbinit" -ex "target extended-remote tcp:" -q -ex "monitor swdp_scan" -ex "monitor debug_bmp enable" -ex "attach 1" -ex "set mem inaccessible-by-default off" build/f7-firmware-D/firmware.elf -ex load -ex quit
Reading symbols from build/f7-firmware-D/firmware.elf...
Remote debugging using tcp:
SW-DP scan failed!
Target does not support this command.
Attaching to program: /Users/salavatd/flipperzero-firmware/build/f7-firmware-D/firmware.elf, Remote target
Attaching to Remote target failed
Loading section .isr_vector, size 0x13c lma 0x8000000
Load failed

I got the same error. Did you manage to fix it ?

No, but I wrote to support and I’m waiting for a response

Same problem here. Any idea?

I haven’t received a response from support yet

Ok, after checking with other boards seems to be an electrical problem. In this case the wifi dev board is not properly connected to the flipper. This can me due to a bad position or a damaged internal connector.
Dissasembly your flipper and check with the polymeter.
Please let me know if this is useful.

Best regards!

It doesn’t work, how can I know exactly what the problem is? The problem has not been solved for a long time

Hello there. I stumbled upon this issue yesterday and have spent probably over 5 hours trying to figure out why it was being caused. Dis-assembling my flipper, drilling out a stripped screw, checking gpio connections, etc…

Have you enabled the debug option in the system portion of the flipper’s settings? Nowhere is that mentioned but it is required for the devboard to communicate with the Flipper. Please let me know how it goes.

1 Like

My God! Enabling the debugging option in the settings solved the problem. It was so simple. Thank you.

1 Like