Guillemot STM DFU Device Driver Fix!

If this driver keeps reinstalling itself and is stopping you from updating your Flipper then here’s the fix. This was a bit of a headache because no matter if I had Device Manager delete the driver it always came back within seconds and Flipper will not update unless you remove this driver so here goes.

  • Delete these 2 folders
    -C:\Program Files\Guillemot
    -C:\Program Files(x86)\Guillemot
  • Go to Device Manager, uninstall the Guillemot STM DFU Device.
  • Reboot
  • Try updating Flipper as normal.
    At this point that rouge driver should not take over and the proper driver should work as intended. I’m assuming from my minimal research that this rouge driver was from a sim racing peripheral that i used. Not sure which one though. Hope this helps.

Protip: you can simply rename C:\Program Files (x86)\Guillemot\DFU_ST to for example DFU_ST_, then go to Device Manager and uninstall the device (I used the “delete driver” option too). Didn’t even need to reboot in my case (flashing an STM32 based drone radio with EdgeTX, EdgeTX Buddy was reporting “Error: Failed to execute ‘open’ on ‘USBDevice’: Access denied.”).

PS: Annoyed that you had to waste time on this? Send Guillemot an email about it and maybe if enough of us do this they’ll fix it.