IR Remote buttons learned but receiver is unresponsive

Hello! I received my Flipper today as a gift and have been excitedly adding all of my remotes to it, however I have one specific remote that controls the blinds in my house via IR that has been completely unresponsive.

FZ seems to pick up the signal from my remote right away, which I assign to buttons, but on button press, nothing happens. I’ve tried relearning it at increasingly closer distances to the receiver with no change in results and now at a loss since everything appears to be working as expected with all my other learned remotes.

If it helps, here is the information from the back of my remote (part lists it as ‘RF’ but it defaults to IR which is what I use):

RF Remote Control: 2984495100
IC: 7316A-RC4U

Thanks in advance! :slight_smile:

Take a look at Taking over TVs with Flipper Zero Infrared Port

The ‘AC’ part could be interested for you, if your shades got a similar protocol and has different signals for positions, instead of simple UP/DOWN, it could explain why it seems unresponsive.

The original remote sends ‘UP’, you copy this signal and send ‘UP’ every time, but the shades are already in this position. It seems nothing happens.

Just a try to explain.

To see how it works. You can save more button presses and load the file into the PulsePlotter at My Flipper

Or maybe flipper is just capturing a part of the necessary command and NOT the full command … ?

Try to LEARN the remote outside the range of th shutter like press the up arrow and learn it will flipper now using flipper inside the range of the shutter does it work one time ?

If not can you check on the IR database if there are any remotes for your brand of shutter ? If so try that as there is the possibility that Flipper is not grabbing the code correctly …

If all fails there are other possibility like wrong frequency, etc …

Based on my usage of the original mode, there don’t appear to be set positions but instead just keeps going “up” until I let go of the button, same for down. I tried multiple instances of the same button with no success.

Sadly learning the button outside of the shutter range did not give me a change in results. I will look up the IR DB to see if there are any alternative solutions for this device. Thanks!

Interesting. Because the normal remote only needs one Command. You can press long ‘Vol+’ and it will go louder. But the press is repeated every [n]ms.

My next hint is: Try to send the captured signal multiple times.

Or: Try to record a longer sequence of the Button press and replay it.

What is the brand/maker of the shutters and remote ?

Maybe your remote doesn’t want to be copied and have some protections like sending the start or the end of the code on another frequency that flipper can’t pick or send some stuff that flipper can’t pick/clone … like to force you to buy a remote from them instead of using one universal remote ? Maybe they use this sort of tech to open doors or things that require some “safety” and they don’t want tjhat your remote opens the gate/shutter of your neighbour that have the exact same one ? Maybe they are using a code system of some sort so that your remote works on your system only and flipper can’t pick up what makes your remote unique … ?

Thanks again for all the suggestions. I tried longer (and shorter) signals with no success. I doubt there is some kind of safety on this remote as I have replaced the remote in the past with another of same make/model but intended for another brand of window blinds (looks like a lot of them us the same mechanism but in different shapes and sizes for all windows), for example mine is Hunter Douglas but the replacement remote says Momenta Platinum. I’ve listed the make/model info in the first post for reference.

Ok, maybe it’s a Flipper limitation then … Maybe someone from the Flipper dev team can check this out ?

Did you try this?

Or maybe compare the saved files that you get from your remote with the files on the link i posted ?

I’ll try this next when I’m home. Thanks again!!

1 Like

Please let us know if it did help and please do compare the saved files of your flipper with the data on those samples. Good luck.

Did you manage to resolve this?

I just had the same situation. Button learned, but the TV does not react

The remote is TOSHIBA CT-RC1US-16.
The TV is a non-smart TV (at least, it does not have apps).

Below, the power button

name: Power
type: parsed
protocol: NEC
address: 40 00 00 00
command: 12 00 00 00

I didn’t test other remotes from flipper irdb because the goal is to understand why a learned remote command doesn’t click on the TV.

I did try learning the button long pressed, however, no luck either: it returns the same 0x12