Issues with Mounting and Formatting SanDisk SD Cards

I have encountered an issue with using SD card on my FlipperZero.
I have purchased and tried three different cards SanDisk Ultra A1 SD Card, with capacities of 16GB, 32GB, and 64GB, but each time I receive the error message “Mounting SD card failed” and am unable to format the card.

The first time I attempt to format the card, I received the message “Cannot Format SD card. File system not ready.” On all subsequent attempts, I received the message “Cannot Format SD card. Internal error.”

I have tried using both the release firmware and the latest version (0.78.1), and have formatted the cards using FAT, exFAT, APFS, and other file systems. In addition to these steps, I have also attempted to resolve the issue by resetting my device, rebooting it, and updating the Flipper software. However, none of these attempts have been successful in resolving the issue with the SD card.

Can anyone provide assistance with this issue? Thank you in advance.

Hello! Can you please try using a 2GB MicroSD (non-HC/XC) card? MicroSD-HC/XC cards often violate the SPI protocol specification, and we use SPI to communicate with the SD card.

1 Like

yep, it helped.

1 Like

Mind sharing the model or a link of the working card?

1 Like