MIFARE Classic 4K, Sectors Read: 32/40

Translated using Google Translate:

We have VisorTech Electronic door lock cylinder

There are 10 doors with this lock. Opened with NFC tag. Flipper read 8 of them without problems.
But 2 locks, although they do not have visual differences, apparently have a different version, and have a different level of protection.

Flipper was unable to correctly read their labels.
Here is what I get when I read it:

MIFARE Classic 4K
ISO 14443-3 (Type A)
UID: 89 08 FC 25
Keys Found: 80/80
Sectors Read: 32/40

I read this label with an Android application: MIFARE Classic Tool and this is what I got:

Then, nevertheless, I opened the file that Flipper saves … Flipper could not read the last 8 sectors, those that differ in size.

Here’s what he saved:

Probably the encoding of the last sectors was not read. Don’t know.

I tried to edit the file manually, according to the data from the MIFARE Classic Tool application.

Now Flipper correctly sees sectors. The file is being read but the lock is not opening.

I decided to check whether the label and the Flipper signal are read equally by the smartphone. They are read differently.
How the label is read, I already showed above, the data set is visible.

The Flipper signal just reads “mark detected”… here’s the screenshot:

Maybe someone has some ideas? How to make it work…

Just to confirm, i have the same problem with my classic 4k Tags.

I know all the keys for this 4k Tag and triple checked that they are in the user dictionary.
Flipper always reads:

Keys found: 80/80
Sectors read: 32/40

Mifare Classic Tool on Android and my PN532 read it just fine.
I also tried some empty chinese Tags - same thing, always 32/40, the last 8 sectors cannot be read.

I am on the latest official 0.65.2 Firmware

Yep, that’s a bug, already working on fixing it in the next release


Here’s the PR with the fix, will merge this into the main branch right after validating that it didn’t break anything else


This works flawlessly, thank you very much!

1 Like

I noticed this was merged into the dev branch and I attempted to try and read a 4k card. It still only read 32/40. Sectors. I’m on dev 3846852f

1 Like