[NFC] Cannot load key file converted from MCT (Mifare Classic Tool) format

Hello there,

Firmware 0.99.1
Hardware 12.F7B9C6

I’ve converted Mifare Classic Tool format file to Flipper Zero format using this tool GitHub - whyn0/FlipperNFC2MCT: Simple Python script to convert NFC dumps from Flipper-Zero to MifareClassicTool format

mct2flipper.py -s 4 ./original.mct ./converted.nfc

Here is example.zip (928 Bytes)

When I try to emulate this file using Flipper Zero, I get “Cannot load key file” error.
I’ve checked the flash, it’s OK. I’ve tried to copy this file from Flipper and compared with converted file on PC, both of them are equal. I’ve tried to compare other nfc keys with this and it looks OK for me.

Could you please help me to undestand, what is wrong with converted.nfc file format? Check out the attachment. Thanks in advance

I see that your card’s SAK is “-78”. I haven’t seen that before, usually it’s a positive value like “08” or “88”. Have you tried to change that?

1 Like

hey mxcdoam,
I hope you’re doing well. Thanks for your message, you helped me a lot :star_struck:

I’ve changed SAK from “-78” to “08” and voila! It works now! Really strange, that I got such strange SAK…

  • SAK Values, or “Select Acknowledge” values, are manufacturer defined values found in the header of ISO 14443 Type A cards, which include the Mifare family (Ultralight, Mifare 1K, DesFire, etc)
1 Like