No longer able to Read with RFID

My flipper is no longer able to read using RFID. I’m still able to emulate and even read raw, but can’t read previously working keycards and fobs anymore. When I try to read a previously working card, it gets stuck on ‘Reading 2/2 PSK’ and a flashing blue light (no signal).

I have tried updating to the newest firmware version, repairing in DFU mode, reinstalling the firmware, performing a hard reset, and factory resetting my flipper.

I took the back cover off the flipper to check the connections and they seem ok. Picture attached.

Anyone else have this issue and was able to fix it? I can’t find a solution

same problem. Hace you solved it?

Hi @Willyboy and @Alraben.

Can you please attach a log from console?

I’m not sure how to get the logs. Are any of these it?
qFlipper-20240116-163320.txt (1.8 KB)
flipper lab log.txt (1.8 KB)

Sorry for late reply. A bit hard time now.

Thanks for logs. Sorry, my bad. I forgot. Log what is useful, in this case, is log from CLI, in debug mode/with debug command.

A log what u provide is after try to read? If not, please try to capture log by - connect you’r FZ, open COM port, enter log command, then open rfid app, select read, try to read token/fob, wait until error happen, then stop logging (and of course then send log here :slight_smile: ).

Maybe, after you try to catch log, please try to hard reboot you’r FZ by holding back button until reboot (at least 30 sec) (ref: Reboot - Flipper Zero - Documentation ). Or, if you are able to disassemble you’r FZ, try to disconnect battery for min. 15 seconds, reconnect, then try read, or with another log.

Another idea, just for sure, if you can, please, do factory reset, and use wiped, or better - another uSD card. Then try to install latest release (for now 0.97.1).

Please, let me/us informed about results of course.

PS1: try to read fob/token both with and without debug mode enabled (in menu-settings-system-debug-[on/off])

PS2: if nothing helps, try to enable debug mode (menu-settings-system-debug, set ON), then go to menu-rfid-extra actions-read raw rfid data. File will be saved, upload it here please. Especially, if you have saved fob/token, try to read same one as a raw, and upload here both raw rdif file and saved file. This may help FZ developers to debug, if it’s a system bug (primarily, if @Alraben have exact same issue). Maybe, @Alraben can you try? Or if not help, can you upload these files too?

Have a nice day. I’ll reply immediatelly when I will be able.

1 Like

Hi Tomi, thanks for your detailed reply.

I’ve attached a log in debug mode. It does not throw an error, rather, it just keeps trying to read indefinitely. What is in the log is after 10 minutes of trying to read an ID card which the flipper was able to read before.

Flipper CLI Log Debug Mode.txt (1.8 KB)

I have tried to hard reboot and factory reset but still does not work. Reading with both debug on/off does not work
Put in a new SD card and updated with firmware 0.97.1 and still cannot read RFID while everything else works fine.

I can read the ID card in RFID Raw. Results and working rfid info attached.

This is looking like a hardware issue. I have submitted a support email and hope they can help me RMA my flipper (37.8 KB)
Working_RFID_Card.rfid (86 Bytes)

If you can emulate and read raw then the issue is NOT hardware related. Try to install un-official firmware and check if it helps ? Try with another SD card ? If the hardware is damaged you can’t read raw, unless read raw is not reading as well (creating empty file like if there is no card there - reading nothing)

I’ve tried a new SD card with the latest official firmware already but doesn’t work.

I’ve had unofficial firmware in the past but re-installing and factory resetting the flipper should have removed that, unless I am missing someothing.

I was saying for you to try to auto-install from SD a non-official version of the firmware like the latest un***** one and see if the problem still does exist.
If so are the cards/fobs that you are trying to read still working properly with the lock device ? Maybe the cards got damaged ?

I’ve done that too. Tried to update/re-intall the one you mentioned but still no luck, can’t read with RFID.
The card and fobs still work fine, I use them daily and they still open doors with no issue.

Then i would say some hardware problem with flipper. Contact tech support.

Same here, Just got mine last week. got around to setting it up today. I cannot get it to read anything except infrared. current firmware installed. Known good rfid, and sub-ghz garage controller, no joy.

What RFID card are you trying to read and what garage door remote are you trying to read ?

@Willyboy, thanks for files.

For now, best way is to wait for support reply/fix.

I was thinking about you’r problem, and I have maybe some additional questions/tips.

When FZ stuck, and you move it away from card, it’s still stuck, or something will change?

What special happen before this issue? For example: using in rainy day, exposed to extreme environment/temperature (low/high), drop to floor, … . Or this issue just happen from day to day? Im just asking for sure.

I was also thinking, “what I will do, if I will have same problem?”. Ignore steps what you have done. That’s only my ideas for you’r inspiration :slight_smile:

SW part: update FW, reflash via DFU, change uSD card, flash oldest FW, then reflash to latest (for example, when you do this, FZ will update RF chip FW also). Maybe also try to read a lot of different types of cards to verify.

HW part: disasssembly FZ, dust cleaning, optically check all PCB’s, check/measurement of antenas (avoiding short circuit), check springs on antenna connectors, cleaning of antenna pods/contacts using special cleaning liquids for contacts.

If you have any news, please let me know.

Have a nice day!