No SD card or database found, on Sub-GHz function.

When going into the Sub-GHz menu I get the “No SD card or database found…” message. I can however record and replay sub signals. and they do actually work. Question is what doesn’t works and why do I get this message.

I tried to fix the issue by:

  • Interchanging SD cards.
  • Formatting SD cards from both Flipper and PC
  • Reflashing firmware with qflipper.
  • Reflashing firmware from SD/update/… using the flipper.
  • Reflashing different firmware, switching between original and unleashed.
  • A mix of the above…

It’s bugging my OCD… :unamused:

Hmm, we’ll have to gather more data. Can you enter the flipper CLI? The easiest way to do this is via

You’ll need to set the log level to “Trace” in your device’s system settings, then reboot and connect it to your PC. From there, run device_info and copy the output to a separate file. Then, run log, and after that, enter the subghz app and click through the warning. Then, also copy the output to a separate file, and attach the files here.

1 Like

Dear Astra, thank you for your assistance.
Below you will find the requested log files. Thank you for pointing me into this direction as i wasn’t aware of the web app. I found some pointers in the log_subghz file.

initial_log.txt (1.3 KB)
log_subghz.txt (2.3 KB)

I’ve added the missing files from GitHub and the error is gone. :slight_smile:

Thanks for pointing me to a solution.

Hm, qFlipper should’ve added that when doing DFU repair, weird…


I had the same problem. Update does not work. Reset over DFU and no database files für subghz.
I cloned the repo from Github and copied the files to the SD Card. No the error ist gone.

it worked for me too, thx :slight_smile:

When I tried device_info, it worked for me, but when I typed log, something kept terminating the connection, and I wasn’t able to get the output for log, as it kept reconnecting and saying “[E][BleGap] Pairing failed with status: 2. Terminating connection.” I was only able to get the output for device_info, which I attached. Also, I noticed it might be due to not enough space in the SD card, but my SD card is 64% free. I also attached a portion of the output for log. Any tips on how to fix this?
initial_log.txt (2.2 KB)
log_subghz.txt (6.3 KB)