Problem emulating IButtons :

Hi there guys, can someone check if it’s still possible to “emulate” IButtons with the latest version of official/stock firmware ?
So far I was not able to emulate the IButtons with my flipper.
I’m not using the official firmware so the problem might be related to a specific firmware branch or hardware related.
I did test read/write and it does work just fine. Since Flipper can only write Dallas format I was thinking intro emulating for example Cyfral to a TMP1 programmer (that can do the 3 formats) to get physical copies of IButtons but apparently my flipper can’t emulate to the programmer any of the 3 formats.
I did test with an actual lift lock - . Flipper can duplicate a working user key and those keys copies do work just fine but emulation is not working at all. Also I did test both pins on the flipper and they are ok. I can make a manual connection to the both 17 pins to the RW IButton and both pins allow for reading/writing so it’s not a problem with pins not making connection as both pins do work to transfer data when reading writing and are just not working with emulation.
Maybe something is broken on the latest version of official firmware ? If not both my locks/devices are not compatible with emulation or the problem is with my non-official firmware.
At any rate it would be great to have an option to directly write to Cyfral/Metakon format as I don’t want to be using emulation of IButtons that much, it makes me uncomfortable to be sticking the pins of the flipper on a lock that might be not working properly and have over-voltage, etc … One thing is to be powering the chip on the button or using emulation of RFid but I’m not very comfortable at making a physical contact with the pins of the flipper on a random lock that might be overpowered, etc…

iButton emulation is working fine in stock firmware. Please, install stock and test it there, as we’re not able to debug issues on third-party firmware forks. Also, our iButton pad is not perfect, and the problem might be that the pogo pins can’t reach your reader, and the pins used for emulation are not the same ones that are used for reading/writing, so the issue might be in there. You can try emulation with the two GPIO wires (as you did with reading/writing) to see if it helps.

Direct writing is coming, but the devs are busy with other stuff at the moment, but we’ll get to this eventually.

Thanks for your fast reply ! I will test this out !

Relatedly, how tolerant are the iButton pins of electrically out-of-spec locks / readers? How easy or difficult would it be for an over voltage (but basically functional) lock to damage a Flipper?

Also, are the voltages to emulate the same as for read/write ?

Is it possible for a hardware fault to prevent emulating but allow read/write or as long as if the device can read/write it should be able to emulate as well unless the “problem” is on the software side or the readers not accepting the emulation ?

Some locks might not deal well with emulation and i only have 2 kind of locks with ibutton to test so my problem of not be able to emulate might even be lock related. At any way i want to discard the possibility of hardware fault. Is there any voltage mesures that i can take with multimeter while emulating to discard hardware fault ? Or if reading/writing possible this is enought to discard hardware fault ?

Hi, today also tried with stock firmware to emulate iButton, but yes it didn’t work.
Maybe the ground pin not good enough and needs stronger spring and a little bit extended length to have better contact.
Maybe I can easily fix it at home?

Making an ideal connector is impossible, we made the best one we could. It it doesn’t make proper contact you might need to clean the reader itself, we’ve heard reports of that helping

There’s no thing as a working but out-of-spec reader. If the voltage is too high then even the original key won’t work.

Read/write voltages can be the same or different, depends on the key. However, if the reading works, then the emulation should also work.

Ok, thanks for the clarification.
On my case it’s not a problem with contacts as they are properly made with the reader, it’s just that emulation simply doesn’t work with the type of readers that i have.
The question about voltage were more on the lines of a broken reader that would have over-voltage that would toast/damage both flipper and keys, so i wouldn’t stick the flipper on a random reader at least without testing with a key first, just in case …
I will try to find other readers to test with.

Yes connector is good, but I think pins should be stronger, they presses very easy, I think springs should be stronger. It will be easier to use when Domophone is a little bit dirty.
Yesterday I tried to client it, but it didn’t help. I’m will try one more time later again.

Some readers have an anti-emulator feature that we are not yet bypassing. Yours probably is one of those.

Basically, they start reading the key, then remove the power for a bit, then start reading it again. If the key doesn’t start from the beginning of its data then it’s an emulator and should be ignored. We can fix this in our software, it just takes time and our iButton/RFID dev is currently busy with RFID RAW

1 Like

The pin strength doesn’t matter, as they will either be fully extended, or compressed because the reader itself pushes on them, they can’t just be both compressed and not touching anything

Ok, thanks for letting me know.

OK, thx.
I’m testing with Vizit, as i see iButton is very old technologu and most new ones start using RFID or even NFC, but NFC fob looks same as RFID one.


No progress…

After all this time, does anybody know how to fix this bug?

Good afternoon. Faced the same problem. I can read the key. Write down too. But when you try to emulate the key, the 1-wire line is pulled up to the power supply and that’s it. I tried on the original firmware and on non-original. When using the ibutton fuzer application, the ds1990 emulation does not work, while the metacom and cyfral keys emulate.

1 Like

First, I can’t reproduce pulling 1W pin to +5 when emulating DS1990, but that can be question of voltmeter’s internal resistance. Second, you should get a copy of Dallas iButton spec, as it’s way more complex than outputting stream of bits forever.

1 Like