qFlipper can't connect to device on Ubuntu

I keep getting an error message on qFlipper stating [RPC] Starting RPC session…
[RPC] Failed to start RPC session: Failed to begin CLI session: Device is not responding. I know it has nothing to do with the device as it works with windows. I updated the firmware via bluetooth. Prior to the firmware update I still had the same error message. It says permission denied, cannot connect to serial port as well. I have tried searching google and tried it all. Nothing has solved the solution

1 Like

Had the same issue on Fedora.
Make sure your user is added to dialout group sudo usermod -a -G dialout $USER .

Try to start qFlipper from console and see the port is used, looks like
[DBG] Trying serial port at /dev/tty*

If it detects as anything different then ttyAMC then you need to add udev rules.
Run qFlipper from terminal with parameters ./qFlipper* rules install.
This will prompt you for sudo and then try lunching qFlipper.

My hero. Running Fedora 37 i3 branch and your advice is still gravy in Nov '23. Thank you

why not the command

sudo ~/Downloads/qFillper rules install ?*