qFlipper File Manager — Public Testing

Great news everyone! qFlipper now has built-in File Manager.
Right now File Manager available only in RC version.
UPDATE: File Manager now available in latest release verison.

Download latest release : https://flipperzero.one/update

Please try this feature and report your feedback in this thread.

Why not use basic Mass Storage device?

Flipper Zero access SD-card via slow SPI interface, so random access to FAT filesystem is very slow, synchronous, and single thread only. So using mass storage driver is impossible.


Any chance you can release an Apple Silicon (arm64) version? I think it just needs a couple of tweaks to the build script, but I can’t get past the libusb requirement when I try it manually.


Hi! The M1 version will come eventually (and probably quite soon), but at the moment you can run qFlipper using Rosetta, should be good enough

UPD: I’ve been told that the M1 version will come after migrating the app to Qt6


It appears this build is only compatible with OS 10.13 or later. Is there some way to make this compatible with OS 10.12 or possibly earlier?

1 Like

Why do we need to support outdated macOS?


Because, believe it or not, a lot of people still use them, including people who bought a Flipper Zero.


I feel sorry for those people, who prefer to use OS version with security vulnerabilities, and choose to not install security updates. Flipper Zero is for advanced users who have basic knowledge of computers.


Errrr…whut?? You feel sorry for people who gave you money and supported your product, waited patiently for months, and upon receiving it finally, are unable to perform the basic firmware update, as instructed, and you think it’s just a matter of choice to not update? Had it not occurred to you that hardware limitations might prevent newer OS’ from running, regardless of choice?

As far as advanced users go, none of us start out as advanced. You didn’t, nor did I. Rather than turning your nose up, and trying to impress with elitism, because you are either annoyed as you consider such a task beneath your magnificence, or you are afraid of failure, why not suggest something productive…like running a Linux Live OS USB, or making a patch?

The fact is that you have made a very cool tool, that obviously a lot of people have bought, and your programming skills are clearly formidable, but it seems like your customer support skills are a bit lacking. I mean we’re not talking about rocket science here, or multi-layer sampling of some esoteric protocols, we’re talking about addressing just the basic necessity of being able to perform the initial firmware update, as instructed on the box, on the site, in the forum, on the unit itself, or on the quickstart sheet with something productive instead of admonishment. Despite indications to the contrary, I believe you can do better.


Come on dude. Time to buy a new mac. Sierra is almost 6 years old and hasn’t been supported by Apple since 2019. It’s out of date. If your mac isn’t 64 bit or something, which is the only reason why you can’t have gotten on a more modern version, it’s time to update it. You’re not getting security fixes either, so you’re running a totally insecure machine and you’re using a security tool. Don’t get mad at others for that.


I’m not mad at others for using newer machines, I’m not mad at others pointing out that my OS is six years out of date, lacks support, or has holes in it. What I find annoying is that the best answer anyone here can give me is “Buy a new mac”, especially in this economy. No work-around suggestions, not even a second thought. Unfortunately, there’s a lack of backward compatibility with certain older tools that I use, and cannot do without, but this is not your issue, it is mine. I’ll figure it out without your support, thanks for nothing. Literally, nothing.

Security tool? Don’t you think that’s kind of a misnomer, as it’s pretty much the exact opposite of a security tool? Think about that.


I understand, it can expensive to upgrade computers. But it is a necessity, people can’t spend time supporting every old version of MacOS going back years. It’s not like the windows ecosystem in that regard and has not been for some time. Apple themselves don’t even support your version anymore.

The current version of macOS is 12.3.1, so you are quite out of date already.

I would suggest adding a dedicated budget for computer hardware every year in your saving plan. That way, when the time comes, like it has now, you can be prepared. Buying an Apple silicon Mac now will likely be a smart move as x86 support is only going to continue to wane.

This tool has many uses, but I’m using it as a pentesting tool. so I consider that a security tool.

Also I’d like to tell everyone to move over to reddit, the flipper zero subreddit. The discussions over there are more fruitful and free. This place seems more like a first line / customer support the way it’s currently being run, so I won’t be posting here from now on.


So let’s see if I got this right. "LULZ, UR shizz 0ld! Do you even code bro??

  1. Learn $$$
  2. Profit

I’m aUd1 n00bz!

mic dr0p"

No matter how you try to rephrase it, it’s still the same response. And it is still wrong. I appreciate your efforts to sugarcoat it, but it’s still just as non-DIY, defeatist, weak-willed, uninspired, and entitled a response as all of the others, so far, along with a nice dose of patronization mixed in. Not as clever as you imagine. If you put even half the effort into questioning as you do into bootlicking, you’d have not only a working solution, but learned something in the process.

Reddit so far is pretty much “What can it do???” yawns


NOTE: I’m just a community member, not an official developer or anything.

I think the lack of support for macOS 10.12 is a bigger problem than just Flipper not putting in the work.

Technical details

qFlipper is a Qt application. Qt 5 for macOS and Qt 6 for macOS both only support macOS 10.13 and higher.

The newest version of Qt that still supported macOS 10.12 is Qt 5.13, or going with the slightly older Qt 5.12 LTS. Qt 5.12 and Qt 5.13 are both outside their support window, which can make supporting them while also supporting newer operating systems more difficult.

Potential workaround for old OS versions

  1. Try to install Linux on your Mac, e.g. through dual-booting

Older hardware has a higher chance of working successfully with Linux anyways.

  1. Install virtual machine software on your Mac, then boot a modern operating system inside that, passing through all the Flipper USB devices during the update process.

I haven’t tested this, but it’s how I’ve successfully updated an unrelated device with Windows-only firmware updates on my otherwise Linux-only hardware.

  1. Use dfu-util from the command line to flash the Flipper firmware in DFU mode

You might also need to extract resources onto the Flipper microSD card manually.

Additional note

Work is underway to add firmware updating via the Flipper Android app. Once you’re on a newer Flipper firmware version, if you have a new-enough Android device you may be able to use this. I would suggest looking into the other options first, though.


Anybody with a “basic knowledge of computers” will understand that there are many reasons why someone might prefer or need to run older versions of an operating system. New hardware doesn’t always do what old hardware did. Updates break existing infrastructure. Older OSs can be much easier to tie down and secure without all the new, unnecessary, untested, unoptimised fluff they add to every major new release to “encourage” you to “upgrade” all round. ts not necessarily about cost but having the best tool to do the job.

On a more productive note is it possible to just put the latest firmware files on the SD card manually and have the flipper update itself as is done with the new mobile app? To me that seems the simplest and easiest way of all and completely removes the computer/phone software/hardware compatibility issues.


on SD card, create “update” folder. unzip the firmware in that folder under “f7-update-XXX” folder. put SD card back in Flipper, go to that folder with file browser, and execute update.fuf.
Problem solved.



I wold like to see some changes in qFlipper:

  1. Resizable qFlipper’s window (to fullscreen)
  2. simple filelist in qFlipper’s filemanager (just sorted list withut big icons)
  3. multiple files selection (deleting tens of files one-by-one with 3-clicks per file is pain)

Is it possible?

P.S. I could turn off the Flipper, remove SD-card, insert it to PC, mount, work with files … but it inconvenient to do it every time i need to remove/download some files.

Less is more, reformatting and starting over with a filtered set is less work then trying to click a 1000 times to remove individual files.

Also you can just putty into it and use cmd-line with the remove command.

Commands to use in serial
storage list /
storage list /ext
storage read /ext
storage write /ext
storage remove /ext/subfoldersomething

help command also lists other options you might want to try

Still inconvenient. No regexp in cli, no cycles, no “if”…
Possibly it is because of small RAM.

One should invent his own “bicycle” with sending commands to ttyACM, read result, parse…
IMHO removing SDcard and work with files in bash (zsh, csh…) is the best method for now.