RFID writing not working at all

I have been unable to write to any RFIDs. I have tried 4 completely different types/brands of T5577 RFID’s including keychain and card style. Reading and all other functionality works great. I have re-flashed firmware to factory to no avail. Has anyone else experienced this or know of a solution?


1 Like

Does the reading work? Are the T5577 chips password-protected? They might be if you’ve used a different cloner before to program them.

The reader works perfectly fine, but when I try to write to any of them it doesn’t work. The most recent RFID’s I purchased were these: https://www.amazon.com/dp/B07GBSP8SD and nothing. Also I have not programmed them on another writer, they are all blank.

Hmm, everything sounds alright

Can you send a video of your flipper trying to write to the tag?

Here you go: https://www.youtube.com/shorts/TnWWJEYYLUA

1 Like

Maybe the chips are EM4305 and not T5577 as they will look the same.
If you have a keysy try to write to keysy blank cards with flipper. Works fine for me. And unlike stuff like ICopy 3/5 or even NFC-PM5, etc Flipper will NOT lock those cards with password so re-writting with other devices will still be possible.

Also try to read the chip and write what was written back to it, if the chip is not supported flipper will attempt to write for a while and will show you a write sucess message, this is because after attempting writting flipper will check by reading and comparing to see if data was written correctly. Even if chip is not supported and even if flipper is not writting at all you will get a write with sucess message if flipper do read the same that it attempted to write,
By the look of your video it does look like the chip where flipper is attempting to write is not supported but please wait for an official answer from someone of the flipper team.

I think I can see the problem

Writing takes a while because we try to write in all possible modulations, and at that time your tag should be fully stationary.

Try holding it against the middle of the flipper for 5-15 seconds, that should probably help

1 Like

@Astra no this is not the case as I have also tried holding RFIDs for up to a minute with no success. I was just showing in the video how the placement doesn’t matter. I have tried this more times than I can count.

Weirdly enough the Keysy keys were writable. They are the only rfids I have been able to write to. All of the other ones I have used are the recommended ones from flipper docs however so I’m not sure why it’s not working

Perhaps someone can share an Amazon link of rfid tags that have worked for them that I can try writing to

Same as me, the keysy ones are the only ones that did work for me as well with flipper RFID but all the others i have are EM4305 so maybe your T5577 chips are in fact EM4305. If you can write to keysy blanks then problem is NOT flipper hardware but firmware instead. Maybe when EM4305 writting is implmemnted your problem is solved. DO NOT write to keysy keys with chineses stuff like the ICOPY 3, 5, super copy king, etc as those will lock the tags with password and they will no longer work with keysy, If you write with flipper keysy tags will still be re-usable with keysy.

1 Like

I bought the same ones you did and mine worked just fine but I wasn’t on the stock firmware.

I even created a TikTok video showing the process. https://www.tiktok.com/@themasterhackerz/video/7122551664027962666?is_copy_url=1&is_from_webapp=v1

In the second part of the video where you say you are writing the display shows “reading RFID”. No matter how much I try I cant write to those cards.

Yeah, kinda weird that it says reading but it wrote it. I made more than 1 copy and tried different cards that I had and they all worked.

I did it again and it worked just fine. Edit: I’m on the new upgraded Unleash, the last one was done with an older version.

Have you found any RFID’s that you couldn’t copy to? It’s either that we both got different internals somehow but the same plastic cover, or theres something wrong with my flipper. It does emulate fine and write to one type of rfid so far.

The problem is definitely in your tags. The enclosure might look the same, but on the inside it can be anything. You’ll need something like a proxmark3 to know for sure what’s wrong with them, but I can certainly say that if you can write to at least one tag, everything is OK with your device

I have the same problem, but if the hex is equal to the token, flipper writes, if it is different it does not.