RFID writing not working at all

Hi again. I think that the Keri issue that you have might be firmware related. Try to update to the latest dev version because on my tests i didn’t had to format to write Keri.

Also if you want to add it to your list, I did test with KeySy blank fobs and i was able to write all formats with exception of AWIG AWID and FECAVA FDX-A but it’s a known bug of the firmware and it’s NOT related to the fobs we are using, once the firmware is fixe we should be able to write those 2 formats properly on our fobs.


Thank you for the update! I’m still not able to write Keri on multiple cards with the latest dev unofficial firmware. Will wait for this fix and the AWID/FDX-A firmware fixes, then try again.

Updated the gist with KeySy. Thanks for testing.

1 Like

I will keep on testing as soon as new updates are released. I need to try now to write something and check if what is read back does equal what was written …

Let’s call this one user error :slight_smile:

I was trying to write 000000AA. Maybe there is a strict checksum or something with Keri that doesn’t like that value. if I write AAAAAAAA as you suggested, all of my blanks work, including the one with the EM4305 chip.

Thanks for the tip!

Re-tested with the update released yesterday. Now ALL formats write OK and read OK as well (read what was written with correct format).

So the list can be updated. Both ebay fobs and KeySy fobs can be written with ALL flipper RFID formats, at least on my test.

I do have trouble with some formats because they don’t allow all random values and you must write an expected/valid format but in general looks like it’s working, i would need a valid card of each format to test further to see if it clones properly, like read original-write on copy-check if copy is equal to original.~~~
I WAS NOT able to write ANY format to ANY of my EM4305, so are you sure your EM4305 fobs are indeed that ? Because i don’t think flipper can write to those at all (yet) so maybe your fobs are not really EM4305 ?!

Thanks for the update! I’m now able to write in all formats on all of my T5577 fobs/cards! This is awesome news.

As far as the ETEKJOY fobs are concerned: I’m not sure what chip they have. They’re marketed as T5577, but I suspect they are not a true T5577 chip because I can only write a limited number of protocols. I assumed that means it’s a EM4305 chip, but I could be wrong.

1 Like

Well … It’s NOT EM4305 for sure … Flipper can’t write on those at all… I’ve many true EM4305 (confirmed with proxmark3) and i’m sure flipper doesn’t write a single format to them as it require different write command. I suspect your chips are “something else” …

enough with your tiktok video please. it doesn’t show writing to the rfid.

Hi, this is happening to me too - I cannot write RFIDs but can read them.

It worked before I did a firmware update to 0.83.1 (previously it was on the stock firmware, bough the Flipper a month or two ago).

I basically cloned a lot of RFIDs with the stock Flipper, did an upgrade, tried cloning more (same RFIDs, everything’s the same) - doesn’t work, it’s just stuck on “Writing” (held it for 20seconds and more).

I would appreciate any help! Thanks.

Factory reset didn’t help either.

Thanks for the list!

This waterproof bracelet works well with H10301: