SD card reader not mounting and power draw is now at 500+ ma

Hello, I received my flipper last month. Everything was working great until while I was transferring some files using qFlipper, it suddenly slowed down and crashed. Ever since, I cannot reformat my original 32gb SanDisk SD card along with 2 other SanDisks (32gb/64gb) that I have tested, both brand new. So I have determined that the problem is not with the SD cards because 1) it worked before 2) I have tested multiple SD cards 3) formatted/reformatted these SD cards 4) The SD cards are readable on a pc and working nicely.

While troubleshooting, and doing things that are written on support on how to fix this problem, like rebooting, factory reset, hard reset/reboot, dfu recovery mode and formatting the sd cards to fat32 on a pc using disk management on windows 10, I noticed that my flipper was getting hotter so I checked the power draw, it is at 500+ma, and stays this way whatever I do. qFlipper says database is missing and it probably wont get fixed until sd card reader mounts an sd card. So now, I cannot do anything with the flipper zero. Ive tried most of the things written here and none have worked. Is there anyone else who has experienced this? Any help would be greatly appreciated thanks.

From my plain knowledge about electronics and some experience with the Flipper I suggest to open the Flipper, pull the battery cable, wait 10 sec, replug and test.

If the test is good, reassemble the Flipper, if not you have a lot of space to see what component is causing the heat and to measure the parts nearby the heatsource.

Thank you for your response. I just did what you suggested but unfortunately it stays the same. With regard to the heat I cannot determine where it is coming from at the moment but it seems to have stopped. Perhaps I need to keep it on for a while.

Is it possible that this information is wrong because databases are missing and no sd card?

Update: GPIO 9,10,11 is extremely hot and painful to touch

I ordered a 2gb SanDisk that is non hc/hx just to make sure its not my cards and sent a ticket to support. Hopefully one will help or my flipper is bricked

If the SD does not fix anything and it is not related to the sensing not working properly, it could be a potential crippled paw in the card-reader itself, but with a bright light you should be able to somewhat see and tell looking into the slot.

Using a flashlight, upon inspection, every paw seems to be intact. SD card slips in and releases smoothly as well. Logs say SD card detected when I put an SD card in but is followed by 10 cycles of internal error.

Do you have anything else to try the sdcard in? To doublecheck if that is just burning down? An old phone with a sd slot? laptop? usb cardreader or camera ? something to verify its working? If that is functioning normally i guess the reconnecting of the battery is next step, just be very gentle, you only need a phillips screwdriver and maybe something plastic to flip open the flatcable lock, softly reconnect it and click the lock back into place, i guess @LupusE is right and the sensing cable is tripping/not connected well. Be very gentle, if you rip the battery cable of the board with the connector you have a entire new problem that is a lot more annoying to fix.

Thank you for your assistance. Yes I have a laptop and pc where the 3 sd cards work fine. I have tried pulling the cable out and waiting then reconnecting but it is the same. Here is a photo of my power_debug

Swapping FW with bootrecovery flash after leaving out the batt for about 10min solved my issues, but for me it would also not properly charge , so the currentdraw is weird, also the temp of 42c is a bit high so i wonder if some software/app is cooking the CPU maybe? If you have a actual short usually you would expect more stuff to stop working.

How do I swap the FW to boot recovery flash? Is this dfu mode by holding left and back button, then releasing back button?

yeah dfu, and maybe clean card, or if you wanna keep it, just move contents to subfolder so you can move it back later, just to check if something is running cripple and making it cook itself if you do not feel like debugging it this way first. At least for me that was always the most easy goto that resolved a lot. Before checking it while open and feeling what is actually hot on the board. Is it actually 42c cause of powerdraw? Do standby/powersettings of backlight change anything. To gain a closer view of what is occurring, after its clean also debug logs will be less trashy to prevent random stuff conflicting.

Ok ive tested reflashing while battery is disconnected and its still the same unfortunately. Im thinking maybe i got a defective sd card reader?

and if you look at the board under a decent light, there is no trash on it? near the reader, connectors, board, or anything on there? I wonder what could cause a short somewhere in the card circuit, something around the cardreader, traces or resistors being very hot to the touch?

It looks clean. Perhaps the power draw is incorrect due to having no databases or sd card? or the SD card reader is not working due to the sudden high power draw?

After disassembling all the parts, ive determined the part which gives off the most heat, its the gpio pins 9, 10 and 11 that are getting super hot. Is there anyway to turn it off?

It could be as easy again as something near the pins/connectors , up to resistors no longer having resistance or worse , the feeling heat on the board is usually a nice way to find out where it is coming from, but without any external devices connected it still cooking, hints at a physical problem.

Not sure on what toys you have at home, but schematics are in the documentation , so depending on how badly you wanna fix it and go find out from here :smiley: I guess near or next to the heat there could be something causing a short cooking it and breaking things, but if there is nothing optically obvious that looks more worn then it should, a multi-meter is more then just handy.

If you have a modular power-supply you could just increase the power and see which part blows of the board first but that’s a bit of retro troubleshooting, so I cannot advise this route without having a pile spare-parts on hand.

Unfortunately I do not have a multimeter. I wish to thank you for all your support. According to the schematics pin 9 3v3 powers the sd card reader so it may be busted already. Physically it looks like everything is good so its not as simple as pushing something or disassembling. I will need help from flipper zero support. Sadly, the ticket has no response.

Sometimes it helps to ask in the Flippers Discord. The staff is more active and sometimes respond more directly, if you have a ticket number.

Thanks will try posting there now

Sounds like a hardware issue like a short circuit or something among those lines draining all of your power very fast…
I would NOT operate flipper like that, would power it down and investigate further, it’s NOT firmware related/software issue so better ask for tech support as running flipper like that will simply cause further damage to it.