I’m trying to get UFBT working, but every time I try to run “ufbt update” I get the following error stack:

my.name@C02F508MML7L FlipperRemote % ufbt update

09:44:00.168 [I] Deploying SDK for f7

09:44:00.168 [I] Fetching version info for UpdateChannel.RELEASE from https://update.flipperzero.one/firmware/directory.json

09:44:00.493 [E] Failed to run operation: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:992)>. See --verbose for details

I’ve updated certifi, I’ve installed and verified openssl, I’ve tried turning off my companies VPN, switching to hotspotting off my phone, nothing seems to get this to work.

Try to open
https://update.flipperzero.one/firmware/directory.json in a web browser.
If it works, I am sure the browser got Proxy settings, the System does not. It could be interesting what certificate is shown for debugging, but we can’t debug your proxy.

You could also do what the message suggest: ufbt update --verbose

I was able to navigate to that, I’d actually tried that before but failed to mention it.

ufbt update --verbose gets me:

my.name@C02F508MML7L FlipperRemote % ufbt update --verbose
usage: ufbt [-h] [--no-check-certificate] [--ufbt-home UFBT_HOME] [--force]
            {update,clean,status,dotenv_create} ...
ufbt: error: unrecognized arguments: --verbose

I was not aware about the sequence of the parameter/arguments: ufbt --verbose update