Vibro not work

Hi I have had a Flipper Zero for a few weeks, I realized that now the vibro no longer works, I tried to reset the Flipper and reinstall the firmware but nothing to do. What can I do? I tried turning the vibro off and then on and even in normal use there is no vibration. Never dropped or hit, always used at home and used official firmware.

While I sent an email to the assistance hoping to answer me as soon as possible


However, the assistance is really very absent. Almost 1 month since I sent the mail and wrote in this forum and no help or advice on how to move.

maybe it shook itself loose or something?

I have very little knowledge of the flipper zero internals, but I imagine that the connection to the motor probably just broke. If your device is not under any warranty, you could potentially try opening it up, tracing the cables from the motor to the PCB, and checking whether the solder is intact.

If it looks cracked, but it hasn’t come loose, you can try heating it with a soldering iron to melt it back together. Do this at your own risk.

Also, you can connect a serial console to the flipper zero and trigger the vibration motor through that to test it

bear in mind it has no auto-off, so even if it doesnt work, make sure to turn it off through the serial console

Thanks for the reply. I bought the Flipper new from a seller on eBay and I contacted Flipper Zero assistance via email to find out what to do, but for almost 1 month I didn’t get an answer. I tried with console but it doesn’t give any sign of life. I have the dexterity to repair it myself, but if it continues like this I will really repair it myself, I am very angry about this bad experience.

Hello! Sorry for the late reply!

If you’re comfortable with disassembling your Flipper by yourself - you can follow this guide to get to the vibration motor (step 19) and inspect it for any visible issues.

Otherwise - please contact [email protected] for further help.

Hello and thanks for the answer. I already sent the email 1 month ago and I didn’t get an answer, I can do it to disassemble Flipper Zero, but won’t I lose the warranty?

Did you receive an automated reply to your email? If you did - please send your case number here, I’ll let our support team know.

Yes, if you disassemble it to fix this issue you won’t lose warranty, as it was our fault. (However, this only applies to situations where you were specifically asked to do it by Flipper Devices staff, for everyone else reading this)

1 Like

Yes here is the code: 998-680203

So as soon as I have some time I take it apart, I was waiting for your reply to figure out what to do. I’m happy that by opening it I don’t lose the warranty because you authorized me

I opened it and found that the cause was a crooked vibro pin. I folded well and closed again and it finally works. Thanks for the help even if it’s late!

1 Like