Wi-Fi Dev Board - not appearing for flash

I’m working on getting the wi-fi dev board online, but I’m having trouble at the very first step, flashing the firmware. I’ve tried on Windows and MacOS so far, and get stopped at the same point. Once I have python/vscode installed, and once I have the fbt package ready to go, I try to push it to the device “./fbt flash”, and get “Is device connected and is System>Debug enabled?” if I haven’t done the hold boot, press reset, release boot, thing, and it says “[ERROR] No available interfaces” if I have. Whenever I perform the “hold boot, press reset, release boot” step, I see the two network interfaces replaced with one in device manager / ls /dev/.cu*, so it should detect, but the dev board has no lights and fbt can’t see it.

I hope that’s easy enough to follow. I haven’t tried to debug yet, but I was wondering if someone else has had these issues yet and might have a quicker answer for me. I’m competent, but not proficient in any development environments.


Did you solve this issue by chance? If I try and flash the device out of boot mode it can be seen and asks you to put it into boot mode, but after the button combos the device can no longer be seen by the flashing tool, but it does bring up something new in the device manager.

I haven’t, but yeah it sounds like we’re having the exact same issue.

Ok… so for me… for whatever reason, the CLI would not work, thus the instructions we both tried to follow would not work. however, manually pulling down the package and flashing worked without issues. I got the FW from here. Flipper Zero · justcallmekoko/ESP32Marauder Wiki · GitHub
instructions are there as well.

1 Like

I was having this same issue but I fixed it. Do this on the flipper, go to Settings>System and scroll down to debug and turn it to on. Fixed it for me and works like a charm.

1 Like

I started down this path, but now when I plug my dev board in, it doesn’t even appear on the list of devices. Device manager doesn’t change, “ls /dev/*” returns identical results before/after plugging in. However, the dev board is behaving the same way it always has - the led shows blue when I plug in and turns red. If I hold boot, led flashes white until I release, and when I release it turns off.

I’m starting to think I just have a busted board.

Web Updater

update your device.

Go to the Web Updater

With your device plugged in, click connect
Use the following table to select the appropriate files and place them at the corresponding address

Bootloader 0x1000
Partitions 0x8000
Boot App 0xE000
Firmware 0x10000

.bin files can be downloaded at the first link

Hey, thanks for the reply and sorry for the long wait - all I’m getting when plugging mine in now is “Unknown USB Device (Device Descriptor Request Failed)” in Device Manager. I will try on MacOS tomorrow. I just can’t get it to appear, no matter what USB cable, jack, etc. I use.

Did you try uninstalling the driver and reinstalling it? It’s also good to try different USB ports. If you’re using a laptop try unplugging it from power so it’s on battery power. Make sure nothing else is plugged into it.

Just tried again from my laptop, no dice. same thing. Not seeing anything on MacOS either. Again, multiple cables, nothing else plugged in, just showing up an an unrecognized usb device.

Did you uninstall the drivers and reinstall them though?

This worked straight away. Thanks.

Issue: When I would run ./fbt flash I would get single error: [ERROR] No available interfaces
Solution: Above
Status: Resolved