Battery Issues? (Battery seems to struggle to charge)

My flipper seems to be experiencing some battery issues. Its draining extremely fast. Its been hooked up to my desktop via usb c cable for the last 4 hours and has only charged from 20% to 24% charge. Battery info shows its still 100% health. Are there issues with the latest firmware causing issues around battery and battery charging, or is my flipper’s battery dying. Was part of the kickstarter, so my flipper is a bit older at this point.

I’m on firmware 0.97.1

Try a reboot with hotkeys.

Yeah I have already tried that. The device it self functions, it just doesn’t seem to charge. I left it plugged in for about two hours yesterday and it only charged maybe 15-20%. When plugged in, the light flashes from red to green. like it starts charging, stops charging, starts charging, stops, etc.

I’ve reset all the settings, ive updated the firmware, but nothing I’ve tried seems to help.

Please see this thread.

Thanks. I grabbed those logs. I can provide them here, but im assuming ill just need to open a support ticket? The only thing i really saw on the linked page was someone was told to open their flipper and unplug the battery and replug it in. figure support should take a look before i go to that extreme. I can send you logs in DM as well if you want.

I could look at them if you want. Maybe I’ll see something.

will DM you logs…

It seems to indicate the Flipper is charging but at a very slow rate. I can’t get an accurate voltage on your Flipper from these logs because it’s being charged.
Go to settings >> Power >> Battery info with the Flipper not plugged in. Let me know what it says there.

charge 26%
temp 22c
volts 3.3
health 100

I can’t see any reason your batter isn’t charging correctly. The voltage is high enough and the temperature looks fine. Health is at 100%. None of the data looked bad to me. A better trained eye might spot something. The charger just doesn’t appear to be delivering enough amps. I assume you have tried different cables(if not then try them). You could attach the Flipper to a dumb wall charger and see if that helps. Make sure to use a USB A to USB C connector. That eliminates some possible USB C related problems.

Yeah, i’ve tried multiple things. usb a → c, usb c ->c, and my raspberry pi power cable. None seem to really help. I put in a ticket and we will see what support says. Thanks for all your help / discourse. its appreciated.

1 Like