Battery stuck at 49%

My flipper worked great out of the box it was fully charged everything was going swimmingly untill it ran out of juice. When I charged it I noticed that the battery level read 49% yet it said charged on the indicator. I’ve also noticed that it power cycles every now and then on its own. What could be going on?

Please, connect it to the PC and run power debug and power info in the serial CLI

If you don’t know how to use CLI, please tell me what OS are you using (Windows, Mac, Linux), and I’ll guide you through this

1 Like

Ok, I’m using windows.

  1. Connect the Flipper to the PC
  2. Open Putty
  3. Connect to the Flipper COM port at 115200 bauds
  4. The Dolphin art should appear

From there just type the needed commands and press return, then copy their output and paste it here

Hi - I am experiencing the same issue. I charged overnight and went from 49% to 51% …

: power debug
bq27220: CALMD: 0, SEC: 2, EDV2: 0, VDQ: 0, INITCOMP: 1, SMTH: 0, BTPINT: 1, CFGUPDATE: 0
bq27220: CHGINH: 0, FC: 0, OTD: 0, OTC: 0, SLEEP: 0, OCVFAIL: 0, OCVCOMP: 1, FD: 0
bq27220: DSG: 0, SYSDWN: 0, TDA: 0, BATTPRES: 1, AUTH_GD: 0, OCVGD: 1, TCA: 0, RSVD: 0
bq27220: Full capacity: 2101mAh, Design capacity: 2101mAh, Remaining capacity: 1067mAh, State of Charge: 51%, State of health: 100%
bq27220: Voltage: 4156mV, Current: 13mA, Temperature: 22C
bq25896: VBUS: 5200, VSYS: 3944, VBAT: 3924, Current: 0, NTC: 60060m%

: power info
power_info_major : 1
power_info_minor : 0
charge_level : 51
charge_state : charging
battery_voltage : 4152
battery_current : 13
gauge_temp : 22
battery_health : 100
capacity_remain : 1067
capacity_full : 2101
capacity_design : 2101

Sorry for the delayed response
here is the info you requested

And now it won’t turn on at all🥲. This device is amazing hope we can get this sorted out.

I’ll send this to our engineers and we’ll see what we can do. In the meantime, please message [email protected] and tell them about your problem (please include your dolphin name, serial ID and power info+debug)

1 Like

@Astra can you share the instructions for Mac/Linux please?

Nevermind, I was able to follow this CLI Command Line Interface Examples - #3 by bughuntr

1 Like

So, I spoke to the engineers and they said that i might have to open it up and unplug the battery and plug it back in. they gave me a instructions on how to do it including the screwdriver size. I have unfortunately stripped the final screw I needed to remove to reach the battery cable. Now my flipper will only work while plugged in. Any suggestions on how I should proceed? I know this was a long time ago and I probably should have reached out sooner but i had a lot going on and this was the earliest i could make it back on here. Thanks again for your help.

I’m having a slightly different problem than OP, but still related to battery/charger.
I’ve borrowed a F0 from a friend of mine who has the Kickstarter edition. I’ve upgraded the firmware on it to the latest version: 0.80.1[28-03-2023].

With the F0 plugged in (and I’ve tried multiple cables, and power sources), the LED on the F0 does not turn on, and the device does not charge. With the cable and computer I’m using currently, the F0 does show up as a serial port, and I am able to use PuTTY to connect to it. Attached is the output from “info power” and “info power_debug”.

Any tips?


Mostly connecting it to power and giving it a reboot with 2buttons is enough to restart the charging process properly, if fw is crippled, try restoring original, then connect it to charger, then reboot it and see if that fixes it, for me this solved all charging issues. /edit: with a lot of applications and lets say less supported fw options i did notice some problems with the power/charging instances, but clean restarts fix them most of the time.

I’ve now updated the F0 to the latest firmware (again), this time being v0.85.2.
The device now has absolutely no battery power, and seemingly will not charge at all.
I attempted thee two-button reset, and it still won’t charge.
Shown below is the “info power” and “info power_debug” output (which has changed between versions).

>: info power
format.major                  : 2
format.minor                  : 1
charge.level                  : 0
charge.state                  : discharging
charge.voltage.limit          : 4208
battery.voltage               : 0
battery.current               : 0
battery.temp                  : -273                : 0
capacity.remain               : 0
capacity.full                 : 0               : 0

>: info power_debug
format.major                  : 1
format.minor                  : 0
charger.vbus                  : 5100
charger.vsys                  : 3664
charger.vbat                  : 2304
charger.vreg                  : 4208
charger.current               : 0
charger.ntc                   : 80055


Any help would be greatly appreciated; I can’t use the Flipper without it being connected via cable, at this point!

For me it helped to disassemble the Flipper, unplug the battery, replug and reassemble.
The website iFixit helps a lot. But you’ll find the 4 screws outside and 2 inside easily.

Link: Flipper Zero Battery Replacement - iFixit Repair Guide

1 Like

I tried that but the the last screw stripped. I need an extractor that will fit something this small.

Not sure why but today it hit me, suddenly it went blank and also charge seemed to be gone. Could not get it back in DFU so also had to take it apart, took out the battery, left it out for a while, put it back together , did a dfu reflash that suddenly worked again and now its is fine again. Be gentle with the plastic it seems a bit fragile/not made to take apart ever week, but it is is a simple efficient design you can click apart pretty easy, just be very gentle on the cable latches.

The solution provided by @LupusE seems to work here, but i managed to cripple the FW multiple times so i guess its part of tinkering around with stuff.

I also noticed on hot days it seems to become a bit slower on some applications, after reassembling it , also those twitches seem to be gone so i guess that is a good next step?

I have some cheap phillips 261 screwdrivers that seems to fit perfectly for screws in it. And the rest is basicly lego?

p.s mine just passed the 52% so i guess its going to 100% within the next hour or so.

1 Like

I followed that procedure, and am happy to report that it worked!
Thank you all for your help!

I was able to pull the stripped screw and got the battery disconnected, I plugged it back in and it all seemed to work. As I was putting it back together, I put the screw that goes next to the ribbon cables, the one that goes through the ibutton board. the unit shut off. I’m guessing there is a short there or the flex in the PCB causes a shot somewhere. I don’t know but I just left that screw off and it’s been working great.