Can't update my Flipper

qFlipper-20240126-093840.txt (28.7 KB)

Do you have an SD card installed? That’s required and based on your log there was an SD card issue.

Full Update @Olikort ERROR: SD Card is not installed or malfunctioning

Yes, i do. it appears Flipper doesn’t recognises SD card. Card itself is fine, i checked.

Have you tried reformatting the SDcard in the flipper itself? I do a lot of work with small devices and have found that formatting a card on another device first can sometimes cause problems.

“internal error” - that’s what flipper says when i try to do that

Tried benchmarking SD card, this is the result:

Please follow Flipper Incs advice on SD cards. Some cards may work fine in a PC or phone but not work in a Flipper.

Use a high-quality microSD card
It is important to use high-quality, branded microSD cards such as SanDisk, Kingston, Samsung, or others to ensure the proper performance of your Flipper Zero. Using low-quality microSD cards may not only result in poor performance but can also brick or even damage your device.

Does that mean my flipper is damaged? In that case is there a specific part that is most likely fried and I can replace it, or do I just throw my flipper in the garbage can?

1 Like

I’d say it’s unlikely there is any actual damage. Just try one of the SD cards from the list Flipper has in the docs. My favorite for reliability is SanDisk.

8gb - 16gb are usually the best prices. You don’t need a big SD card. Cards under 8gb usually cost more then the 8gb cards.

Tried Kingston, Samsung and SanDisk, none worked for me.

1 Like

Does the Flipper show an SD card image in the top left corner?
If it does show the SD card image does that image have any kind of slash or X through it?

SD card does show up, but there is no X or / through it

1 Like

That suggests the SD card is recognized properly. The Flipper must be updated to an official firmware build before you can try to update it to any custom firmware.

Is this the first time you are updating your Flipper?

Are you updating the Flipper to an official firmware or a custom firmware?

Have you tried DFU(recovery mode)?

No, it’s not my first time, I’m updating to official firmware, DFU works fine but error shows up when using it with SD card in place

Have you solved the problem?My flipper also meets the same problem。I have already changed cards and repaird the equitment 。But it still shows internal error。

I don’t usually recommend this but it might be worth a shot. See the section " Using SD card to update with custom firmware"

I believe this is the most recent firmware file at time of writing. i t must be extracted.

If anyone is looking at this in the future make sure you don’t grab the rc or dev version unless you know what those are. They may not be stable but all the builds are in the folder below.

No, I have no idea what to do.

doesn’t help

1 Like

Have you factory reset the Flipper from the menu and “Reboot with hotkeys”? I’m pretty much out of ideas.

Nothing works :frowning:
I’m gonna be honest with you, I did use low quality SD card before it did something weird with my flipper because I didn’t have a better one at hand.
And all things considered I think my problem is in hardware, card reader specifically. I tried looking at schematics for flipper boards but I guess I’m to stupid understand how they work.

Any idea what can be broken in my case?