RFID writing not working at all

:cry: :cry: :cry: :cry: thx

I do have several bags of 100 units that i did get from ebay and they are very cheap and all EM4305 … Even when buying T5577 there is no certain way to know that they will not ship you EM4305 because they are just the same visualy (look the same on the outside). Mines are cleared marked as EM4305 on the bag and i can write/re-write to them with other devices like the icopy and the NCF-PM5…

Fully true.

To follow up on this …

I’M NOT AFFILIATED WITH THIS SELLER BUT … I did buy those : (leaving here for reference) - 50pcs New RFID 125KHz Writable Rewrite T5577 Keyfobs Proximity Access Tags | eBay

And they FULLY WORK !!!

Those are REAL T5577 and they look like NFC blanks. The posted pictures of the amazon listing look exactly the same as my EM4305.

Tested to write Indala and IoProx. Tested with my work access card (IoProx) and it duplicates fine, flipper writes ok and reader detect the copy as original.

Another photo (sorry for bad quality)

My advice is to avoid chips that look like EM4305 as flipper can’t yet write to those…

Furthermore if i read my empty new tags i do get this :

While i can’t get a thing out of my empty/un-written EM4305 ones (i only get data if i write to them with other tools) Flipper can READ from written EM4305 but will not get a thing from full empty ones (will keep on trying to read them).

Just a follow up, i did FORMAT my new tags with KeySy and flipper now keeps attempting to read them using both methods without managing to do so unless i do write again to the tags,

Meaning the ones i did get and mentiones were simply pre-written by the seller with that empty EM41000 value.

And this reminds me … it would be GREAT to have an option on flipper to FORMAT the cards/fobs …

I am having similar issues with these exact fobs.

I am able to write EM4100 type cards fine, but am unable to write H10301 type cards.

Do you know which type isn’t working for you?

1 Like

Out of curiosity, I tried writing every format that Flipper supports. Here’s what worked with the https://www.amazon.com/dp/B07GBSP8SD fobs:

  • EM4100
  • Indala26
  • IoProxXSF
  • Viking
  • Jablotron

I saw the last post and out of curiosity attemped it myself.

With the latest version of thenon-official most popular firmware branch and the fobs from the ebay listing I did post several post ago I was able to WRITE nad re-read back a pattern of AA on ALL available formats with exception of :


All the others work out for me.

Thanks for the update! I’ve ordered a few different sets from Amazon to give this another go with different hardware. If none of them work out, I’ll check out the eBay link. I just didn’t want to wait that long for them to arrive :slight_smile:

My order of https://www.amazon.com/dp/B09QRYCTZD arrived today and I’m able to write and read back all formats except AWID, FDX-A, and Keri.

Much, much better success with these!

Maybe we should keep a running list of recommended options. I have two more orders coming tomorrow and Tuesday of different types. I’ll advise how they work out.

1 Like

Putting together a list here: Rewritable RFID blanks for Flipper Zero · GitHub

I will try later today with KeySy blanks but the “problem” might be firmware related … Also try to format your cards first prior to write Keri as Keri reads in PSK and the fact that the cards have data on it might prevent writing … Unfortunatly you will need something else to format the cards as Flipper doesn’t support it yet.

Ahhh, thanks for letting me know about that Keri quirk! I don’t have anything to format these, so I’ll have to wait to finish testing. I’ve marked Keri as unknown for now, but assume it’ll work if I’m able to format them.

I got a batch of clamshell cards today that were very performant. I updated the gist.

Hi again. I think that the Keri issue that you have might be firmware related. Try to update to the latest dev version because on my tests i didn’t had to format to write Keri.

Also if you want to add it to your list, I did test with KeySy blank fobs and i was able to write all formats with exception of AWIG AWID and FECAVA FDX-A but it’s a known bug of the firmware and it’s NOT related to the fobs we are using, once the firmware is fixe we should be able to write those 2 formats properly on our fobs.


Thank you for the update! I’m still not able to write Keri on multiple cards with the latest dev unofficial firmware. Will wait for this fix and the AWID/FDX-A firmware fixes, then try again.

Updated the gist with KeySy. Thanks for testing.

1 Like

I will keep on testing as soon as new updates are released. I need to try now to write something and check if what is read back does equal what was written …

Let’s call this one user error :slight_smile:

I was trying to write 000000AA. Maybe there is a strict checksum or something with Keri that doesn’t like that value. if I write AAAAAAAA as you suggested, all of my blanks work, including the one with the EM4305 chip.

Thanks for the tip!

Re-tested with the update released yesterday. Now ALL formats write OK and read OK as well (read what was written with correct format).

So the list can be updated. Both ebay fobs and KeySy fobs can be written with ALL flipper RFID formats, at least on my test.

I do have trouble with some formats because they don’t allow all random values and you must write an expected/valid format but in general looks like it’s working, i would need a valid card of each format to test further to see if it clones properly, like read original-write on copy-check if copy is equal to original.~~~
I WAS NOT able to write ANY format to ANY of my EM4305, so are you sure your EM4305 fobs are indeed that ? Because i don’t think flipper can write to those at all (yet) so maybe your fobs are not really EM4305 ?!

Thanks for the update! I’m now able to write in all formats on all of my T5577 fobs/cards! This is awesome news.

As far as the ETEKJOY fobs are concerned: I’m not sure what chip they have. They’re marketed as T5577, but I suspect they are not a true T5577 chip because I can only write a limited number of protocols. I assumed that means it’s a EM4305 chip, but I could be wrong.

1 Like

Well … It’s NOT EM4305 for sure … Flipper can’t write on those at all… I’ve many true EM4305 (confirmed with proxmark3) and i’m sure flipper doesn’t write a single format to them as it require different write command. I suspect your chips are “something else” …

enough with your tiktok video please. it doesn’t show writing to the rfid.