Wifi board listed in device manager, update saying "Wifi board not found" using windows 11


I’m using latest build of windows 11. I successfully put the wifi board into bootloader mode (I see it in the device mgr). I run the firmware update command and its saying:

PS C:\Users\thoma\flipperzero-firmware> py -m ufbt devboard_flash
scons: Entering directory `C:\Users\thoma.ufbt\current\scripts\ufbt’

fbt: warning: Folder app: manifest application.fam is missing
LoadAppManifest, line 33, in file “C:\Users\thoma.ufbt\current\scripts\fbt_tools\fbt_apps.py”
python C:\Users\thoma.ufbt\current\scripts/wifi_board.py
2023-11-12 16:52:58,243 [ERROR] WiFi board not found
2023-11-12 16:52:58,243 [INFO] Please connect WiFi board to your computer, hold down BOOT button and press RESET button
scons: *** [phony_devboard_flash] Error 1
PS C:\Users\thoma\flipperzero-firmware>

having the same issue. Without bootlader the python script reads:

device found but not in bootlader mode. when in bootloader it’s not detected at all but shows in device manager with a yellow asterisk. Is there some fix you found? any new drivers requiring installation?

I ran into the same issue, but I’m on a mac m1.
Maybe the fix will be near the same for Windows 11.

M1 Mac
Python 3.9.13

After this step: python3 -m ufbt devboard_flash

I got the error:

fbt: warning: Folder app: manifest application.fam is missing

LoadAppManifest, line 33, in file “/Users/userdir1/.ufbt/current/scripts/fbt_tools/fbt_apps.py”

python3 /Users/userdir1/.ufbt/current/scripts/wifi_board.py

Fixed by:

Finding the GitHub repo: https://github.com/flipperdevices/flipperzero-firmware/blob/dev/applications/drivers/application.fam

and copying the file to my: /Users/userdir1/.ufbt/current/scripts/fbt_tools

Reran: python3 -m ufbt devboard_flash

Got the ‘wifi board flashed successfully’.

Don’t know why the application.fam file didn’t get downloaded orginally, but finding the file repo and putting it in the proper directory seems to have work.

I tried this and still doesnt work :frowning:

At this point I’m running FBT from github not even ufbt so it must be a driver issue imo

So best I can figure is how the python script is checking for the device. It is clearly looking for “ESP32-S2” when it is looking for the bootloader mode, which leads me to believe that it not having a driver isn’t a huge deal. However, Windows 11 seems to be storing/classifying this as an “Other Device” and not a port. I’m going to see if I can play around with it some and get it working right.


[email protected]

I’m having similar issues. I’m starting to think the board (or perhaps the Wifi chip) may be the problem. I can get unofficial firmwares to load (rhymes with Car-au-der) but I only get the error from the official firmware install (same as above).

Does anyone know how to verify that it’s a hardware problem, and hopefully get a replacement?

Update. I’ve been able to get the Wifi to respond by restoring the official firmware. I provided some details in this post.

I still haven’t reached my goal of making Marauder work, but I think this demonstrates that the Wifi feature on the Dev Board works. (Basically, it seems to be a software/firmware/user problem and not a hardware problem at this point.)

Another update… Geez I finally figured out my problem - the Dev Board wasn’t properly seated on the Flipper. Somehow I missed that you have to press down until it clicks.

The pins were only partially making contact. Rather than not working at all, it was only partially working. I could send commands to it, but it wasn’t responding (guess one of the TX pin was making contact but the RX pin wasn’t).

Bottom line - be sure to press the Dev Board into the Flipper until it clicks (this works even with the Silicone Case).